Author Topic: Connection Problems  (Read 595 times)

Dante101

  • Undead Slayer
  • ***
  • Posts: 102
Connection Problems
« on: February 19, 2019, 09:33:36 PM »
In recent months, I have been experiencing multiple occurrences where it seems that my connection to PotM lags terribly, with a greater than 30 second delay from when I start an action (aka, click on a chest) to when it completes (opens the chest).  And then takes another 30-60 seconds to even load the inventory page of what's in the chest, for example. Others can see what I write, but there's an equally long delay from when I hit Enter to send my message and when it actually displays in my chat log.   I can't inspect items, send tells in a timely fashion (though others can see what I write, it doesn't show up in my chat log), or really interact with the game at all.  It seems to happen at random, where I could be logged in for hours before suddenly everything comes to a standstill and lags like mad.

Resetting my modem and router seems to help on the one time I've tried it, but the issue returns after a couple minutes, leading me to believe it's not the problem.

When running a tracert, it appears I consistently have problems with the 7th jump when trying to trace to the server. When I don't time out on it, it shows that it's ae-1-3113.ear2.London1.Level3.net [4.69.132.138].  But most of the time I run the tracert it times out.



I'm at a loss as to what to do to fix it, as I'm no network engineer. And I guarantee you that if I were to call my ISP (Comcast), they'd ask me to just restart my router, pull up a Google page, and say "well you have internet, so you're good!"

Curious if anyone else has been experiencing similar problems?

Dante101

  • Undead Slayer
  • ***
  • Posts: 102
Re: Connection Problems
« Reply #1 on: February 19, 2019, 11:12:33 PM »
Quick report out on this - I tried running the game a few hours later with a free trial of a VPN, and it completely resolves my lag issues.  When using the VPN, I experience absolutely no lag.  Without it, I found intermittent delays in my actions, such as opening doors or "rubberbanding" when trying to move my character.

If you're experiencing these problems but don't believe you have internet connectivity issues otherwise, I recommend trying the free version of Hotspot Shield (https://www.hotspotshield.com/).  It worked great for me, at the recommendation of a fellow player!  You're allowed 500MB per day of bandwidth against the free version, which should last you quite a while if all you're doing while running it is playing NWN.

zDark Shadowz

  • Undead Master
  • ****
  • Posts: 344
Re: Connection Problems
« Reply #2 on: February 19, 2019, 11:27:07 PM »
Well, glad to hear that you have resolved it somehow. When I read this below...

Resetting my modem and router seems to help on the one time I've tried it, but the issue returns after a couple minutes, leading me to believe it's not the problem.

... On top of the other feedback it sounded like your internet connection was being delayed significantly, and I would've suggested either see if anyone else on the connection is running something on their computer or if something on your computer was running in the background that shouldn't have been. (Windows Update bugging out is notorious for killing internet connections, for instance). Last thing to check is what WiFi channel your router is using compared to everyone elses, if it's not on exactly the same channel or distanced enough away then the overlap can cause internet issues as well, and to set it to Auto if it wasn't already, usually should sit on channel 1, 6 or 11 to prevent overlap.
Currently playing Karaz Steel, the Knave with the Glaive.

Dante101

  • Undead Slayer
  • ***
  • Posts: 102
Re: Connection Problems
« Reply #3 on: February 19, 2019, 11:33:17 PM »
Well, glad to hear that you have resolved it somehow. When I read this below...

Resetting my modem and router seems to help on the one time I've tried it, but the issue returns after a couple minutes, leading me to believe it's not the problem.

... On top of the other feedback it sounded like your internet connection was being delayed significantly, and I would've suggested either see if anyone else on the connection is running something on their computer or if something on your computer was running in the background that shouldn't have been. (Windows Update bugging out is notorious for killing internet connections, for instance). Last thing to check is what WiFi channel your router is using compared to everyone elses, if it's not on exactly the same channel or distanced enough away then the overlap can cause internet issues as well, and to set it to Auto if it wasn't already, usually should sit on channel 1, 6 or 11 to prevent overlap.

Thanks for the quick response! I was experiencing no connectivity issues with anyone else on the network, was streaming music just fine, and was in voice chat to try troubleshooting -- with no lag evident in either the music or the voice chat.

Additionally, I'm on a hard lined ethernet connection with 150mbps download speed for my package with my ISP. So WiFi shouldn't have done it either. Appreciate the feedback though!

DM Nocturne

  • Sanguis Noctis
  • Dungeon Masters
  • Dark Power
  • *
  • Posts: 3255
  • Vampires don't do dishes
Re: Connection Problems
« Reply #4 on: February 20, 2019, 01:15:32 AM »
I have the same issues; occasional and unpredictable packet drops and ping timeout issues ever since Potm went EE. Didn't have this issue on v1.69.

Something along my route is also causing problems. No connectivity problems to other applications so I don't think it's on my end. Will have to try a better free VPN service and test further.

Nemonic

  • New to the Mists
  • *
  • Posts: 31
Re: Connection Problems
« Reply #5 on: February 20, 2019, 02:47:07 PM »
Chiming in to say I'm also experiencing similar intermittent issues and never had them before EE. Coincidence maybe, as I was away for a long while before EE was adopted, but who knows. Good thinking on the tracert Dante, I should try the same.

Ercvadasz

  • Dark Power
  • ******
  • Posts: 1098
Re: Connection Problems
« Reply #6 on: February 23, 2019, 07:12:03 PM »
detto and i have 300 Mbit connection, also NOT that far physically from server neither....
Often lags, rubberbanding, strange lag where only certain quickbuttons are not functioning appropriately.

Oh right perhaps cold add which app you use. Beamdogs? Steam or GOG?
I use Steam.
« Last Edit: February 23, 2019, 07:17:24 PM by Ercvadasz »
Currently playing:
Rudrig von Rachenthall - the travelling merchant

zDark Shadowz

  • Undead Master
  • ****
  • Posts: 344
Re: Connection Problems
« Reply #7 on: February 24, 2019, 01:25:40 AM »
If you haven't already, make sure all your game settings for Steam are set so that they don't update games while you're playing.
Currently playing Karaz Steel, the Knave with the Glaive.

Dante101

  • Undead Slayer
  • ***
  • Posts: 102
Re: Connection Problems
« Reply #8 on: February 24, 2019, 02:07:07 AM »
I highly, highly recommend switching to VPN service whenever you experience these major lag events.  As noted in one of my earlier posts in this thread, the VPN made an incredible difference for me when I used it - but it'd be good to have others test it to see if they have similar results!