Author Topic: Frame rate drops and random crashes on EE  (Read 1202 times)

XayneZ

  • New to the Mists
  • *
  • Posts: 26
Frame rate drops and random crashes on EE
« on: July 30, 2018, 03:28:49 AM »
In the northwestern farmlands outside of Vallaki going towards the fishing lodge, about 5 seconds after the transition, I will randomly drop down to between 5 and 10 fps before crashing to desktop if I stay in the zone for too long.

Something similar happens when I leave the Krofburg tent city, although that's typically just an instant crash to desktop.

For reference, I have 16gb of RAM and am running a GTX 1080ti, so I really don't think I should be chugging so badly in these areas. Is there anything I can do and are these normal problems?
A somber song may grow into blissful crescendo

dazza555

  • Undead Master
  • ****
  • Posts: 259
  • Calibardbarian
    • http://morningstarani.deviantart.com
Re: Frame rate drops and random crashes on EE
« Reply #1 on: July 30, 2018, 12:34:48 PM »
I think the Kroftburg crash is quite common, I'm almost certain it was happening to some players pre-EE, dropping my settings to minimum helped alleviate it a bit.

HM01

  • The Underworld
  • Undead Slayer
  • ***
  • Posts: 111
  • The Iron Paradise
Re: Frame rate drops and random crashes on EE
« Reply #2 on: July 30, 2018, 04:18:29 PM »
I've noticed this from time to time, mainly in the Eastern Farmlands, on the way to VoB - Right out of Vallaki.

Fungal Artillery

  • Undead Slayer
  • ***
  • Posts: 241
Re: Frame rate drops and random crashes on EE
« Reply #3 on: July 30, 2018, 04:47:03 PM »
Grass was a big one for me. Turn it all the way off. Water effects might be chewing that FPS too. And anti-aliazing used to cause problems too, I haven't tested if that's still the case.
"A man in a robe, claiming communion with the divine? Madness." - Narrator, Darkest Dungeon

A minor Glamour

  • Undead Slayer
  • ***
  • Posts: 136
Re: Frame rate drops and random crashes on EE
« Reply #4 on: August 01, 2018, 09:18:59 AM »
I've noticed this from time to time, mainly in the Eastern Farmlands, on the way to VoB - Right out of Vallaki.

I had this problem, I noticed that my graphics drivers where updated and it appeared to either give me a bunch of new settings I never had before, or it cranked my existing ones right up to maximum, I'm not sue I don't really pay much attention to my Nvidea control panel. So I lowered them, and cleared out my override folder, I was using the Ravenloft launcher and I noticed it was updating overrides, so I figured I might have had some more overrides added that contributed to it. Since then I have been running smoothly now.

Silas Rotleaf

  • Dark Lord
  • *****
  • Posts: 932
  • Space cat!
Re: Frame rate drops and random crashes on EE
« Reply #5 on: August 01, 2018, 03:43:46 PM »
Ghakis is still laggy and crash prone as hell for people from time to time (this has been a long standing issue since even before the migration to EE as far as I know). Maybe if the shaders to that tile set get tweaked a bit?
Advice we always give people is set video settings at their lowest for when you are around there on your Neureni excavations and Krofburg delivery runs.
« Last Edit: August 01, 2018, 03:47:32 PM by Silas Rotleaf »

Fungal Artillery

  • Undead Slayer
  • ***
  • Posts: 241
Re: Frame rate drops and random crashes on EE
« Reply #6 on: August 01, 2018, 03:51:03 PM »
There is definately something fishy going on with the NVIDIA settings. I just cranked down everything I could from the NVIDIA options for NWN EE and the game became way smoother, despite having cranked most things down from the game's own options. My PC should have no issue running this game either.

Anyway, I would suggest looking at the NVIDIA settings and turning things off. I don't have the time atm to isolate the exact troublemaker here, but I feel like one of the culprits is in there.
"A man in a robe, claiming communion with the divine? Madness." - Narrator, Darkest Dungeon

A minor Glamour

  • Undead Slayer
  • ***
  • Posts: 136
Re: Frame rate drops and random crashes on EE
« Reply #7 on: August 23, 2018, 10:52:00 AM »
Well the framerate is dropping once again in these areas...

Lake Zarovitch South Western Shore

Barovia - Old Svalich Road, Crossroads (by far the worst affected area I've noticed)

Barovia, Vallaki, Northwestern Farmlands.

I think the culprit are sounds, because closest to sources of water the framerate is worse, and towards the edges of the maps close to the transitions the framrate improves slightly, although its still bad. Once I transition outside of the areas framerate instantly goes back to normal. Could someone have a look at the area and see if there are any other things that could be causing issues, and also tone some of the sounds down?

It would be much appreciated by those affected.

Tycat

  • The Tabasco Bandit
  • Theatre de la Cathedrale
  • Dark Power
  • ******
  • Posts: 2787
  • Discord: Tycat#2415
Re: Frame rate drops and random crashes on EE
« Reply #8 on: August 23, 2018, 11:52:54 AM »
If it helps, I noticed that snow causes a lot of this for me. In the winter times I turn grass off and most of the other visual effects to compensate for snow, and also because the world wouldn't be so lush anyway in the winter so why not. Might help you out.

XayneZ

  • New to the Mists
  • *
  • Posts: 26
Re: Frame rate drops and random crashes on EE
« Reply #9 on: August 23, 2018, 12:51:38 PM »
I think it was actually rain that was causing my frame drops, managed to deal with it by lowering the fancy textures of pretty much everything.
A somber song may grow into blissful crescendo

A minor Glamour

  • Undead Slayer
  • ***
  • Posts: 136
Re: Frame rate drops and random crashes on EE
« Reply #10 on: August 26, 2018, 10:44:27 AM »
Snow and rain doesn't have any affect on my computers performance and lowering the in game options doesnt help either  :(

It's really frustrating because I have a computer that can handle much more demanding games than Neverwinter Nights, and it's only curtain locations that have any affect on it.

A minor Glamour

  • Undead Slayer
  • ***
  • Posts: 136
Re: Frame rate drops and random crashes on EE
« Reply #11 on: August 26, 2018, 03:36:23 PM »
Aha, I have an update, I've resolved the issue. Unfortunately this is unlikely to be anyone else, but it turns out that my PC came with a Internal High Definition Audio Bus, and unbeknownst to me it was disabled by default. So I enabled it, and sound effects in games are actually better, and the areas I was having trouble with seem to be OK now. So I guess check your sound settings guys and girls.

Fungal Artillery

  • Undead Slayer
  • ***
  • Posts: 241
Re: Frame rate drops and random crashes on EE
« Reply #12 on: September 25, 2018, 12:29:05 PM »
I was introduced to a fix that significantly decreases random crashes (that we all playfully refer to as being Enhanced).

My Files -> Neverwinter Nights -> nwn.ini file

Under [Video Options]  tweak MaxTextureMemory. It's probably 60. We need to raise it. Example that works below:


[Video Options]
MaxTextureMemory=256



Thank you to Dante101 who introduced me to this fix and whomever it was that introduced it to him.
"A man in a robe, claiming communion with the divine? Madness." - Narrator, Darkest Dungeon

HM01

  • The Underworld
  • Undead Slayer
  • ***
  • Posts: 111
  • The Iron Paradise
Re: Frame rate drops and random crashes on EE
« Reply #13 on: September 25, 2018, 01:12:09 PM »
[Video Options]
MaxTextureMemory=256

Thank you to Dante101 who introduced me to this fix and whomever it was that introduced it to him.

Holy Christ on a cracker, I owe you guys beers. This is absolutely the fix.