Author Topic: ㅤ  (Read 1864 times)

Ard

  • Undead Slayer
  • ***
  • Posts: 127
  • Exploit theoretician
« on: May 12, 2016, 08:00:51 AM »
« Last Edit: November 08, 2017, 12:39:10 PM by ㅤㅤㅤ »

Arawn

  • CC, Developers, and
  • Dungeon Masters
  • Dark Power
  • *
  • Posts: 9149
  • Gwrandewch ar y cwn.
Re: Borderless windowed
« Reply #1 on: May 12, 2016, 09:28:39 AM »
In theory you should be able to set the resolution in windowed mode to fill your screen.
Hir yw'r dydd a hir yw'r nos, a hir yw aros Arawn.

DrXavierTColtrane

  • Dark Lord
  • *****
  • Posts: 739
Re: Borderless windowed
« Reply #2 on: May 12, 2016, 10:31:48 AM »
This might work:

http://westechsolutions.net/sites/WindowedBorderlessGaming/

Of the games tested with it, 176 do, 7 don't.

NWN is not on either list.
For everything that's lovely is
But a brief, dreamy, kind delight.

Skullmonkey

  • Outlander
  • **
  • Posts: 52
Re: Borderless windowed
« Reply #3 on: May 12, 2016, 11:14:14 AM »
This might work:

http://westechsolutions.net/sites/WindowedBorderlessGaming/

Of the games tested with it, 176 do, 7 don't.

NWN is not on either list.

It should work, as i remember trying it out. Although is not perfect it should do the trick

Dumas

  • Dark Power
  • ******
  • Posts: 1204
Re: Borderless windowed
« Reply #4 on: May 12, 2016, 11:16:26 AM »
I've got my Neverwinter Nights set up running in a large window but not full screen. It allows me to simply click on the parts of my desktop that show around the window to easy switch away from the game to access other programs, then click or alt tab or select the start bar icon of the game to enter without any problems.

You'll still have the program window bar at the top and around the edges, but if you set up the desired size to be slightly under your native desktop resolution, you won't really see much.

You have to edit the nwn.ini text file in your Neverwinter Nights install folder. The lines you need to edit are under [Display Options]. You need to make sure that FullScreen and AllowWindowedMode equal the following values.

FullScreen=0
AllowWindowedMode=1

Next you'll need to edit Width and Height to be a value slightly smaller than your desktops native resolution dimensions. In my case, running my native desktop in 1920 x 1080, I selected to play the game window in 1600 x 900. This allows me to have a decently large window for my game. You can change the value to anything you want, however... for instance, if your desktop is 1920 x 1080, you can select a value of 1900 x 1060 and have a similar effect.

You might be able to eliminate the border by tweaking these settings in this file more, so I'd suggest experimenting with some of the values. You can't really break anything, as long as you just save a copy of the text file as a back up.




Phantasia

  • Dark Lord
  • *****
  • Posts: 822
  • Bout Dat Wo
Re: Borderless windowed
« Reply #5 on: May 12, 2016, 11:47:50 AM »
I'm actually pretty sure that you can only get a windowed mode of any lower native resolution of your monitor (or NWN game), you can't actually set random dimensions and get it to output. The next lower dimension is 1680 x 1050. There is a fix I found on the EFU forums, but apparently it could fry your monitor or so the guy that wrote this says. Use at your own risk, if it even works, or even legit.

Fix.
Characters: M.J. Harding - Minstrel, among other things...

mf_hansen

  • Outlander
  • **
  • Posts: 62
Re: Borderless windowed
« Reply #6 on: May 12, 2016, 11:58:22 AM »
No luck on my end with WindowedBorderlessGaming yet. Here are my findings:

The tool DOES remove the NWN window border, also moves the NWN window to the top-left screen coordinate, and it also expands the NWN window to your bottom-right screen coordinate.

The problem is NWN still only renders its graphics in a sub-region matching the resolution you set in your nwn.ini file. Following Dumas' directions and then setting Width and Height to match my native resolution sadly forces NWN into fullscreen mode, regardless of the FullScreen and AllowWindowedMode settings.

I then tried increasing or decreasing the Width and Height settings by one pixel each, but this reverts NWN back to a 800x600 render. It seems for NWN window mode to work you MUST use a Height and Width that is supported in-game, and it MUST be less than your current monitor/OS resolution to prevent fullscreen OpenGL render (like Sword stated).

Good find though; if anyone else feels like tampering with WindowedBorderlessGaming, here is my config.ini for comparison. You may also want to experiment with the tool author's simplified version of DxWnd as an alternative tool or supplement (see link for download/instructions though I doubt it works for OpenGL games like NWN). You may also have to avoid using NWNCX_Loader if present during such tests.

PS: Nice idea for a dirty fix, Sword; seems like it is basically an autohotkey script that briefly increases your monitor resulution to the one in red, then lowers it back to the resolution in blue (see article for explanation). This circumvents the NWN restriction I mentioned earlier, but if your monitor/OS has no higher safe resolution to use temporarily, that fix might also be out of the question and/or unsafe to use.

PPS: Myself and others have also suggested GLintercept for fixing specific Nvidia GPU issues; note that this simply intercepts and blocks specific OpenGL render calls to improve compatibility with certain graphics cards, it does NOT magically convert NWN's OpenGL graphics into Direct3D graphics. The only/main reason why NWN requires DirectX for Windows is that it allows DirectSound3D for positional audio; the Linux native (older?) version of NWN I believe simply reverts to Miles audio or OpenAL or similar audio.
« Last Edit: May 12, 2016, 12:14:25 PM by mf_hansen »
Forum PM or tell mf_hansen in game or chat on Discord between 17:00-22:00 GMT.

gainreduction

  • Cool Dungeon Bro
  • Undead Master
  • ****
  • Posts: 265
Re: Borderless windowed
« Reply #7 on: May 18, 2016, 11:55:51 PM »
No luck on my end with WindowedBorderlessGaming yet. Here are my findings:

The tool DOES remove the NWN window border, also moves the NWN window to the top-left screen coordinate, and it also expands the NWN window to your bottom-right screen coordinate.

The problem is NWN still only renders its graphics in a sub-region matching the resolution you set in your nwn.ini file. Following Dumas' directions and then setting Width and Height to match my native resolution sadly forces NWN into fullscreen mode, regardless of the FullScreen and AllowWindowedMode settings.

I then tried increasing or decreasing the Width and Height settings by one pixel each, but this reverts NWN back to a 800x600 render. It seems for NWN window mode to work you MUST use a Height and Width that is supported in-game, and it MUST be less than your current monitor/OS resolution to prevent fullscreen OpenGL render (like Sword stated).

Good find though; if anyone else feels like tampering with WindowedBorderlessGaming, here is my config.ini for comparison. You may also want to experiment with the tool author's simplified version of DxWnd as an alternative tool or supplement (see link for download/instructions though I doubt it works for OpenGL games like NWN). You may also have to avoid using NWNCX_Loader if present during such tests.

PS: Nice idea for a dirty fix, Sword; seems like it is basically an autohotkey script that briefly increases your monitor resulution to the one in red, then lowers it back to the resolution in blue (see article for explanation). This circumvents the NWN restriction I mentioned earlier, but if your monitor/OS has no higher safe resolution to use temporarily, that fix might also be out of the question and/or unsafe to use.

PPS: Myself and others have also suggested GLintercept for fixing specific Nvidia GPU issues; note that this simply intercepts and blocks specific OpenGL render calls to improve compatibility with certain graphics cards, it does NOT magically convert NWN's OpenGL graphics into Direct3D graphics. The only/main reason why NWN requires DirectX for Windows is that it allows DirectSound3D for positional audio; the Linux native (older?) version of NWN I believe simply reverts to Miles audio or OpenAL or similar audio.

Yes. It doesn't work. :'(