You have been taken by the Mists

Author Topic: Video card issue?  (Read 1424 times)

MAB77

  • Developers
  • Dark Power
  • *
  • Posts: 2666
Video card issue?
« on: December 29, 2014, 03:02:54 AM »
Hi all, I have a new computer, everything works well, and now that I have an NVIDIA card instead of an ATI Radeon I no longer crash every hour or so when playing the game. BUT... whenever I walk or run with my character the screen freezes slightly for a fraction of second between each steps. It's not enough to truly annoy me or prevent me to play but it is there nonetheless. I play with minimal video settings to avoid all the other usual problems NWN comes with. Video card is a GeForce GTX 760, system has 12 GB ram on a 3,5 Ghz Intel motherboard, running Windows 8 and playing at 1920x1080 60mhz display resolution on a 27" screen. I tried a lower resolution on a smaller screen and it does the same. Any ideas?
Best Regards!
MAB

Proud member of the Dev team, kindly working nights and days to bring you all more creative ways to slay all your PCs, faster and more efficiently!

Dhark

  • Dark Power
  • ******
  • Posts: 1143
  • Ladul !
Re: Video card issue?
« Reply #1 on: December 29, 2014, 06:30:41 AM »
This post will demonstrate how clueless I am about computing..

Have you tried reducing the number of processors the game uses by editing the NWNplayer.config ?  set cpu affinity to 1 I think

Also you have to run the propgram in XP SP2 mode as administrator
« Last Edit: December 29, 2014, 06:41:38 AM by Dhark »

Kendric98

  • Dark Power
  • ******
  • Posts: 1682
  • Omnipotent Overlord of the Omniverse!
Re: Video card issue?
« Reply #2 on: December 29, 2014, 11:53:50 AM »
This post will demonstrate how clueless I am about computing..

Have you tried reducing the number of processors the game uses by editing the NWNplayer.config ?  set cpu affinity to 1 I think

Also you have to run the propgram in XP SP2 mode as administrator
Your advice seems to fix most problems.

Samson/Tatyanna Costella

MAB77

  • Developers
  • Dark Power
  • *
  • Posts: 2666
Re: Video card issue?
« Reply #3 on: December 29, 2014, 12:43:49 PM »
Alas no improvements, but thank you for giving it a try.
Best Regards!
MAB

Proud member of the Dev team, kindly working nights and days to bring you all more creative ways to slay all your PCs, faster and more efficiently!

Jeebs

  • Dark Lord
  • *****
  • Posts: 951
Re: Video card issue?
« Reply #4 on: December 29, 2014, 01:13:47 PM »
Are you running NWN in compatibility mode? I have windows 8.1 with an Nvidia card and other than the Balinoks crash issue, I've not had this problem you're mentioning. The settings I'm using are compatibility for WinXP SP2, running as administrator and disable display scaling on high DPI settings.  Give that a try and see if it helps. If not, you may have to wait for Blue or someone who's got more experience trouble-shooting NWN tech issues.

Super Sugar

  • Undead Master
  • ****
  • Posts: 275
  • For the Avariel!
Re: Video card issue?
« Reply #5 on: December 29, 2014, 01:21:09 PM »
GeForce GTX 760

I have heard of this issue in other games when using nVidia products.  Most of the time, there was a collision between How your nVidia Utility hands out graphics details profiles to games and then how the games themselves handle their own graphics details.

You may need to tweak the utility a bit.
I like my sugar with coffee and cream.
 - Imrae Zauviir

Ercvadasz

  • Dark Power
  • ******
  • Posts: 1110
Re: Video card issue?
« Reply #6 on: December 29, 2014, 09:02:05 PM »
Hi all, I have a new computer, everything works well, and now that I have an NVIDIA card instead of an ATI Radeon I no longer crash every hour or so when playing the game. BUT... whenever I walk or run with my character the screen freezes slightly for a fraction of second between each steps. It's not enough to truly annoy me or prevent me to play but it is there nonetheless. I play with minimal video settings to avoid all the other usual problems NWN comes with. Video card is a GeForce GTX 760, system has 12 GB ram on a 3,5 Ghz Intel motherboard, running Windows 8 and playing at 1920x1080 60mhz display resolution on a 27" screen. I tried a lower resolution on a smaller screen and it does the same. Any ideas?

had that issue on my laptop, and it was with the nvidia card as well.
I managed to get slightly better performance by reducing allmost EVERY special detail. And reducing it to res of 800x640. With that I was able to eliminate most of these occurances. (No shadows and flickering lights etc.)

Also I am guessing that you have an intel computer. However it would be good to get some more information. Like if it is a laptop or a dekstop. (Also 3.5 GHZ intel is the processor, not the motherboard ;) )
Because if it is a laptop, then most likely there is a hybrid technology used, that basicly means that if a game is launched then instead of the processor integrated videocard/or mobo integrated  (which most likely is an intel 4+++) the dedicated one is fired up(the GTX)  and used.
If so you can turn off the dedicated videocard for THIS GAME ALONE, and that should also help. (I think this was my final solution but not sure, perhaps i had to make some adjustments to the ini file, cant recall since latelyi  had to tinker with a number of ini files.)

To be able to offer you more help, please check the receipt of your computer. It should either state the parts which you bought, and got built-in (either by you or the company) or it should state which "allready built" computer you bought. (Like which alienware or whatever you guys fancy there, of course this only applies to desktops. For a laptop the type of the laptop might be enough.)
Currently playing:
Rudrig von Rachenthall - the travelling merchant