You have been taken by the Mists

Author Topic: Weird Crashes  (Read 1909 times)

Vagabond_OG

  • New to the Mists
  • *
  • Posts: 44
  • Vallaki Garda
Weird Crashes
« on: December 10, 2014, 12:58:49 PM »
So this is a bit weird; and so far I've not been able to figure out the issue, I've exhausted my ability to isolate the problem so I figured it wouldn't hurt to ask here.

Whats been happening for awhile now, is that I'll start nwn up and log in and i'll be able to run around for 5 or 10 min. before my game locks up and crashes. I have to crtl-alt-delete to to end the task. Then when I start nwn back up again after the initial crash it's fine and I don't crash anymore. But it never fails one crash, then it's fine.  I cannot figure out what is going on here.  My system specs are as follows:

OS: Windows 7 Home Premium 64 bit
CPU: AMD FX 8320 Eight Core Processor  3.5 Mhz
GPU: AMD  Radeon HD 7700
RAM: 16 gb: 8 GB Ripsaw and 8 GB Corsair
HD: WD 2 TB


Some things that I've tried thus far are, I updated my display drivers, I've edited the nwn.ini file to accept multiple core processors, and I am running nwn in compatibility mode Windows XP.  I've also disabled shiny water in game as I know that has always had issues.

So any advice or suggestions anyone has would be greatly appreciated :)

IDreamofDaleks

  • Guest
Re: Weird Crashes
« Reply #1 on: December 10, 2014, 01:08:59 PM »
Are you in Windowed Mode or are you in full screen mode?
Do you have windowed mode enabled?
Did you try bringing the graphics into Compadibility mode just for testing purposes?
Do you have any overrides in your override folder?
Do you try to (This is random) alt tab out as soon as you log in then tab back in again, I've noticed this makes me less crashy if I do it once.
Disabling the intro movies also makes me crash less.
Have you run the critical rebuild regardless of whether or not it is asked for? (http://neverwintervault.org/project/nwn1/other/patch/169-critical-rebuild-english)
This seems out of date, but apparently updating DirectX (not just your vid driver) can work, GoG reccomends: http://www.gog.com/support/neverwinter_nights_diamond_edition/frequent_crashes_or_crash_at_startup

This is all I've got..

Vagabond_OG

  • New to the Mists
  • *
  • Posts: 44
  • Vallaki Garda
Re: Weird Crashes
« Reply #2 on: December 10, 2014, 02:10:46 PM »
Are you in Windowed Mode or are you in full screen mode?
Do you have windowed mode enabled?
Did you try bringing the graphics into Compadibility mode just for testing purposes?
Do you have any overrides in your override folder?
Do you try to (This is random) alt tab out as soon as you log in then tab back in again, I've noticed this makes me less crashy if I do it once.
Disabling the intro movies also makes me crash less.
Have you run the critical rebuild regardless of whether or not it is asked for? (http://neverwintervault.org/project/nwn1/other/patch/169-critical-rebuild-english)
This seems out of date, but apparently updating DirectX (not just your vid driver) can work, GoG reccomends: http://www.gog.com/support/neverwinter_nights_diamond_edition/frequent_crashes_or_crash_at_startup

This is all I've got..

Thanks! I'll give those a try.  I do not have windowed mode enabled. The only overrides I have I think are like portrait packs, music packs, etc. Just the potm ones.  I also just yesterday did the critical rebuild.  I did not think of DirectX i'll update that and see if it helps! Thanks for the advice!

Arael

  • Undead Slayer
  • ***
  • Posts: 151
Re: Weird Crashes
« Reply #3 on: December 10, 2014, 02:29:53 PM »
So this is a bit weird; and so far I've not been able to figure out the issue, I've exhausted my ability to isolate the problem so I figured it wouldn't hurt to ask here.

Whats been happening for awhile now, is that I'll start nwn up and log in and i'll be able to run around for 5 or 10 min. before my game locks up and crashes. I have to crtl-alt-delete to to end the task. Then when I start nwn back up again after the initial crash it's fine and I don't crash anymore. But it never fails one crash, then it's fine.  I cannot figure out what is going on here.  My system specs are as follows:

OS: Windows 7 Home Premium 64 bit
CPU: AMD FX 8320 Eight Core Processor  3.5 Mhz
GPU: AMD  Radeon HD 7700
RAM: 16 gb: 8 GB Ripsaw and 8 GB Corsair
HD: WD 2 TB
Why that video card? :(

Anyway I heard about multi-core issue with NWN.

Vagabond_OG

  • New to the Mists
  • *
  • Posts: 44
  • Vallaki Garda
Re: Weird Crashes
« Reply #4 on: December 10, 2014, 03:08:04 PM »
No particular reason. I've had AMD cards before and never had any issues. I am going to be buying an nvidia card  first part of the year I think.  It's just frustrating the frequent crashes.  I cannot figure it out :\

IDreamofDaleks

  • Guest
Re: Weird Crashes
« Reply #5 on: December 10, 2014, 03:45:26 PM »
The only time I ever had a major issue playing NWN in the last 10 years is when I had an NVidia /Intel Graphics set up.

So...I think its more or less a crap shoot this late into the game's life.

Vagabond_OG

  • New to the Mists
  • *
  • Posts: 44
  • Vallaki Garda
Re: Weird Crashes
« Reply #6 on: December 10, 2014, 07:41:29 PM »
The only time I ever had a major issue playing NWN in the last 10 years is when I had an NVidia /Intel Graphics set up.

So...I think its more or less a crap shoot this late into the game's life.

Yeah unfortunately :\ all the sites I looked at for help were at least a couple of years old.

Arael

  • Undead Slayer
  • ***
  • Posts: 151
Re: Weird Crashes
« Reply #7 on: December 12, 2014, 04:32:02 AM »
No particular reason. I've had AMD cards before and never had any issues. I am going to be buying an nvidia card  first part of the year I think.  It's just frustrating the frequent crashes.  I cannot figure it out :\
AMD cards are good. But that video card is unbalanced compared to the other components.

Anyway I have crashes too, during specific circumstances.

Vagabond_OG

  • New to the Mists
  • *
  • Posts: 44
  • Vallaki Garda
Re: Weird Crashes
« Reply #8 on: December 12, 2014, 08:42:19 AM »
Oddly enough. It seems to be somewhat resolved now, why? I have no clue but I am good with for the time haha

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20694
    • http://www.nwnravenloft.com
Re: Weird Crashes
« Reply #9 on: December 12, 2014, 09:11:41 PM »
So this is a bit weird; and so far I've not been able to figure out the issue, I've exhausted my ability to isolate the problem so I figured it wouldn't hurt to ask here.

Whats been happening for awhile now, is that I'll start nwn up and log in and i'll be able to run around for 5 or 10 min. before my game locks up and crashes. I have to crtl-alt-delete to to end the task. Then when I start nwn back up again after the initial crash it's fine and I don't crash anymore. But it never fails one crash, then it's fine.  I cannot figure out what is going on here.  My system specs are as follows:

OS: Windows 7 Home Premium 64 bit
CPU: AMD FX 8320 Eight Core Processor  3.5 Mhz
GPU: AMD  Radeon HD 7700
RAM: 16 gb: 8 GB Ripsaw and 8 GB Corsair
HD: WD 2 TB


Some things that I've tried thus far are, I updated my display drivers, I've edited the nwn.ini file to accept multiple core processors, and I am running nwn in compatibility mode Windows XP.  I've also disabled shiny water in game as I know that has always had issues.

So any advice or suggestions anyone has would be greatly appreciated :)

Does it just crash you out of the game and to your desktop? If so, do you notice any weirdness with sound/music, such as stuttering?

Bluebomber4evr: The Justice, not you, since 2002

Vagabond_OG

  • New to the Mists
  • *
  • Posts: 44
  • Vallaki Garda
Re: Weird Crashes
« Reply #10 on: December 13, 2014, 09:03:17 AM »
No not exactly. What happens is that I'll log in run around a bit then my game will freeze (which has resulted in many deaths! :P).  Then i'll have to ctrl alt delete and end the task to close nwn. But when the game does freeze up on me whatever sound is going on will almost get stuck in a loop until I am able to end the task.

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20694
    • http://www.nwnravenloft.com
Re: Weird Crashes
« Reply #11 on: December 13, 2014, 01:25:39 PM »
No not exactly. What happens is that I'll log in run around a bit then my game will freeze (which has resulted in many deaths! :P).  Then i'll have to ctrl alt delete and end the task to close nwn. But when the game does freeze up on me whatever sound is going on will almost get stuck in a loop until I am able to end the task.
Yup, I got those kinds of crashes all the time until I bought a sound card and stopped using the on-board Realtek audio chip. Those things are crap.

Bluebomber4evr: The Justice, not you, since 2002

Vagabond_OG

  • New to the Mists
  • *
  • Posts: 44
  • Vallaki Garda
Re: Weird Crashes
« Reply #12 on: December 13, 2014, 01:33:13 PM »
You know I never considered that.  But, yeah I use the on-board realtek audio chip too. I even have an old sound card from my old comp I could plug in and try that out. Thanks for the advice man!