Author Topic: For some reason the forum's post preview feature isn't working for me?  (Read 1767 times)

A normal snake

  • SsSSSSsssss
  • Dark Power
  • ******
  • Posts: 3750
  • Ssss
It just stopped working last week, has anyone else experienced this issue?

Tycat

  • The Tabasco Bandit
  • Theatre de la Cathedrale
  • Dark Power
  • ******
  • Posts: 2787
  • Discord: Tycat#2415
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #1 on: October 26, 2014, 07:53:52 PM »
It was working for me today and yesterday. I tend to preview new threads for FOREVER to make sure formatting is right. What browser are you using?

A normal snake

  • SsSSSSsssss
  • Dark Power
  • ******
  • Posts: 3750
  • Ssss
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #2 on: October 26, 2014, 08:04:07 PM »
Firefox 27, I'm using an older build because after 29 I think it was they changed the UI to be horrible. I dislike Chrome's UI, so Firefox's switch to a Chrome UI was disappointing. And Chrome flat out doesn't have some of the functionality I use Firefox for.

RedwizardD

  • Scrollord
  • Dark Power
  • ******
  • Posts: 1001
  • Avoid Attention - Critical Failure
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #3 on: October 26, 2014, 09:29:48 PM »
I noticed this started happening recently for me as well within the past few days. I use an older version of Firefox also.

A normal snake

  • SsSSSSsssss
  • Dark Power
  • ******
  • Posts: 3750
  • Ssss
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #4 on: October 26, 2014, 09:32:03 PM »
Hmm. So it's possibly an issue related to firefox then.

Lucadia

  • Dark Power
  • ******
  • Posts: 1293
  • Feral Mystic
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #5 on: October 27, 2014, 12:12:11 AM »
I have this issue for past week and a half. for me do a post preview I had use chrome

Lady Dwayna

  • Undead Slayer
  • ***
  • Posts: 182
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #6 on: October 27, 2014, 12:49:40 AM »
I've also been having this issue. I use Firefox, but mine is up to date. *shrug*

Tycat

  • The Tabasco Bandit
  • Theatre de la Cathedrale
  • Dark Power
  • ******
  • Posts: 2787
  • Discord: Tycat#2415
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #7 on: October 27, 2014, 01:13:27 AM »
I am using chrome and have no problems. I tested it as well on Internet Explorer and had no problems. I am thinking this is a firefox issue as well.

Arael

  • Undead Slayer
  • ***
  • Posts: 151
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #8 on: October 27, 2014, 08:42:34 AM »
Firefox 27, I'm using an older build because after 29 I think it was they changed the UI to be horrible. I dislike Chrome's UI, so Firefox's switch to a Chrome UI was disappointing. And Chrome flat out doesn't have some of the functionality I use Firefox for.
You can download an addon to customize most recent FireFox version to older UI.

Call me old, but I use FireFox 32 but the graphic is like FireFox 3.6

Just to say, preview doesn't work here neither, preview works only on quick reply mode.

Error code report:

Code: [Select]
TypeError: XMLDoc.getElementsByTagName(...)[0] is undefined

var i, preview = XMLDoc.getElementsByTagName("smf")[0].getElementsByTagName("preview")[0];
« Last Edit: October 27, 2014, 08:47:30 AM by Arael »

A normal snake

  • SsSSSSsssss
  • Dark Power
  • ******
  • Posts: 3750
  • Ssss
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #9 on: October 27, 2014, 11:55:23 AM »
Testing on Chrome, preview works, I'll take your word that it works on IE too. Man, firefox got bad after they fired the CEO.

What is the name of the firefox mod that makes the UI like the old one? And are there any mods that make Chrome work like Firefox used to? The integrated search is useless, I want an independent search bar where I can customize what search engines I use. And I want a mouse UI, if I'm eating or drinking coffee I'm not going to be using all of the stupid keyboard shortcuts. I want to be able to customize the UI to have a bookmark window button, tab button, stop button (in addition to the forward/back/refresh). And I still have no idea how to get FTP to work on Chrome, it seems integrated but whenever I try to use it, it doesn't work.

Tycat

  • The Tabasco Bandit
  • Theatre de la Cathedrale
  • Dark Power
  • ******
  • Posts: 2787
  • Discord: Tycat#2415
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #10 on: October 27, 2014, 12:45:54 PM »
Personally I like chrome better after i adjusted to it. Way more intuitive. But I agree. I used to be a firefox purist until it started to suck worse than IE.

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #11 on: October 27, 2014, 12:59:10 PM »
Man, firefox got bad after they fired the CEO.
I don't think that has anything to do with it, and that guy was only a CEO for like, 2 weeks at the most. Besides, I don't think a bug in viewing forums is so horrible that Firefox should have kept a known bigot in their employ to somehow prevent it.

Bluebomber4evr: The Justice, not you, since 2002

Syl

  • Dark Power
  • ******
  • Posts: 2474
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #12 on: October 27, 2014, 02:00:51 PM »
I've been having this problem and I have internet explorer on my laptop

Monica O'Sullivan: Master explorer
Tsubaki Yamamoto: Shadow Thief
Roesor Cryso: A slave for the Masters.
Sokol: An Unlikely Hero

A normal snake

  • SsSSSSsssss
  • Dark Power
  • ******
  • Posts: 3750
  • Ssss
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #13 on: October 27, 2014, 02:39:40 PM »
Quote
Besides, I don't think a bug in viewing forums is so horrible that Firefox should have kept a known bigot in their employ to somehow prevent it.

What? These are two entirely unrelated issues and is not what my post said at all. My post was about the general quality of the browser, which is why I am using an older version of it which has the functionality I want out of Firefox. There are many issues which could cause the preview posting issue, I am posting here in hopes that someone might know if there is an add-on compatibility issue that causes it or if it is an issue with forum software that is effecting other areas. Java updated recently even, I've had the issue for about as long as that update so maybe it has to do with that. Of course the CEO that stepped down some time ago wouldn't be able to magically prevent something like this from happening, when there are so many other factors at play when it comes to website software.

Arael

  • Undead Slayer
  • ***
  • Posts: 151
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #14 on: October 27, 2014, 02:39:54 PM »
I already wrote where the issue is.
What is the name of the firefox mod that makes the UI like the old one?
Classic Theme Restorer.

https://addons.mozilla.org/it/firefox/addon/classicthemerestorer/

It customizes almost everything, you can have very fun with it.

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #15 on: October 27, 2014, 03:17:16 PM »
Anyway, I was starting to think this bug is related to an update to the forum software that was implemented a few weeks ago, since the issue seemed to crop up right about the same time I implemented the fix. I did a search on SMF's forums and found this:

http://www.simplemachines.org/community/index.php?topic=528614.0

So it's not Firefox, it's SMF. They're aware of the issue and will fix it.

Bluebomber4evr: The Justice, not you, since 2002

Tycat

  • The Tabasco Bandit
  • Theatre de la Cathedrale
  • Dark Power
  • ******
  • Posts: 2787
  • Discord: Tycat#2415
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #16 on: October 27, 2014, 03:36:44 PM »
WOOT. Blue to the rescue!

A normal snake

  • SsSSSSsssss
  • Dark Power
  • ******
  • Posts: 3750
  • Ssss
Re: For some reason the forum's post preview feature isn't working for me?
« Reply #17 on: October 27, 2014, 06:10:29 PM »
Thanks Blue!