You have been taken by the Mists

Author Topic: Strange Graphical Bug  (Read 821 times)

Theorem Of Neutrality

  • Undead Master
  • ****
  • Posts: 453
  • It Do
Strange Graphical Bug
« on: May 09, 2014, 11:23:25 PM »
So, I've made the unwise decision of trying to run NwN on Windows 8. I've been mostly successful, save for two odd graphical bugs. As far as I can tell, it seems to stem from the PotM haks, and has something to do with my new rig's graphics card.

Graphic Card: ATI Radeon 6580

The first problem seems to be PotM specific. All the custom armor parts, save for a few, show up as mirrory and glossy, like they use the mirror hidden color. Also, I noticed that I might be missing a few resources from the PotM hakpaks, as the door to the Lady's Rest was just missing, totally absent. I messed around with haks a bit, all CEP models work just fine, and the base game didn't have this issue. It only seems to happen on the server and one the character creator that I've installed the haks.



The second problem deals with my graphics card, as far as I can figure. While all the landscapes are high resolution and textured, all the character models, armor models and placeables are very low res. I've messed around graphics both in-game and out and there is nothing that seems to raise the resolution on these things.

Any insights? I can give more screenies.
Zivon de'Scusa - The Core's best Doctor Doom cosplayer since 752.

dutchy

  • Dark Power
  • ******
  • Posts: 4706
  • Potm's own forum troll
Re: Strange Graphical Bug
« Reply #1 on: May 09, 2014, 11:25:01 PM »
unsure but digg around i think there was a topic with stating windows 8 and certain graph cards not playing nice together

Tagdar Stonebeard- the lone statue
Mihas Mandruleanu- He is the law
Gurdan- priest of the allfather, and current head of the silverhand trading company

Theorem Of Neutrality

  • Undead Master
  • ****
  • Posts: 453
  • It Do
Re: Strange Graphical Bug
« Reply #2 on: May 12, 2014, 03:34:46 AM »
I think I may have stumbled across the problem. After mucking about in the toolset, I realized that my game lacks the full color palette for some reason.

Pretty sure I'll just have to do a full reinstall, sadly.

Edit: Fixed. If you get the game from GOG, make sure you download and run the Critical Rebuild! The GOG version of the game is updated incorrectly.
« Last Edit: May 12, 2014, 05:02:51 AM by Theorem Of Neutrality »
Zivon de'Scusa - The Core's best Doctor Doom cosplayer since 752.

Kendric98

  • Dark Power
  • ******
  • Posts: 1682
  • Omnipotent Overlord of the Omniverse!
Re: Strange Graphical Bug
« Reply #3 on: May 12, 2014, 04:15:01 AM »
Good luck im trying Tues to resolve the issues with my win 8 compatibility issues.

Samson/Tatyanna Costella

Korvenus

  • New to the Mists
  • *
  • Posts: 2
Re: Strange Graphical Bug
« Reply #4 on: May 22, 2014, 01:01:58 AM »
I'm having this same issue but on a Windows 7. Can you Direct me to where I download this critical Rebuild?

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: Strange Graphical Bug
« Reply #5 on: May 22, 2014, 12:22:44 PM »
I'm having this same issue but on a Windows 7. Can you Direct me to where I download this critical Rebuild?

http://nwvault.ign.com/View.php?view=Other.Detail&id=1505

or try this: http://files.bioware.com/neverwinternights/updates/windows/english/NWNEnglish1.69HotUUpdate.exe (I don't know if this still works)
« Last Edit: May 22, 2014, 12:27:27 PM by Bluebomber4evr »

Bluebomber4evr: The Justice, not you, since 2002

LoLJohnFerro

  • Dark Power
  • ******
  • Posts: 1248
  • Currently playing: Dragoon Sae'rid
Re: Strange Graphical Bug
« Reply #6 on: May 22, 2014, 04:17:15 PM »
You can also try to fix this by reducing your own graphical settings, lowering it to worst quality then bringing it back up could fix the issue. It has for me in the past.