You have been taken by the Mists

Author Topic: Help please - it does not run smooth  (Read 4868 times)

DM Macabre

  • Dungeon Master
  • Dark Power
  • ******
  • Posts: 8481
Help please - it does not run smooth
« on: September 15, 2011, 05:31:01 PM »
Hey geeks,

I got a new laptop but NWN does for whatever reason not run smooth on it. I guess I need to configure the nwnplayer.ini and some other settings to make it so. Can anyone of you who knows give me some tips how to do this?

My system is the following:

Asus U30SD series
Intel Core i5 @ 2,3 GHz
Win 7 64 bit
4 GB RAM
Grafic: NVIDIA GeForce GT520M 1GB DDR RA and on board grafic card - tho I am not sure how to switch between those two

currently I run:
-: Curse of the Wolf :-
-: The Curse of von Zeklos :-

Seniies

  • Undead Master
  • ****
  • Posts: 304
Re: Help please - it does not run smooth
« Reply #1 on: September 15, 2011, 06:09:15 PM »
http://www.sevenforums.com/tutorials/316-compatibility-mode.html

If that don't work you have to alter the video card settings.
Get out while its fun.

Romar Notten

  • Guest
Re: Help please - it does not run smooth
« Reply #2 on: September 15, 2011, 07:43:11 PM »
A post I had made about Windows Vista and running nwn, despite you running Win 7 I'm assuming it should still work the same way.

A friend of mine whom which I play Neverwinter Nights with on server has a Vista OS and constantly experiance performance issues (lagg for short) so after browsing the web for about a hour and going by suggestions and feebacks I managed to solve his problem as how now plays without even the hint of lagg. I would suggest trying "Step Three" before the others.


Step One: (Nivida Graphics Card With Control Panel Only)
Spoiler: show

Right-Click On Your Desktop
Select  Nividia Control Panel
Select  3D Settings
Select  Manage 3D Settings
Select  Program Settings Tab
Select  Neverwinter Nights (nwnmain.exe)

Settings Listed Under (nwnmain.exe) "Suggested Changes"
Grayed Out                                  Ambient Occlusion
Off                                               Anisotropic Filtering
Off                                               Antialiasing - Gamma Correction
Off                                               Antialiasing - Mode
None                                            Antialiasing - Setting
Off                                               Antialiasing - Transparency
Use Global Setting                        CUDA - GPUs
Use Global Setting                        Maximum pre-rendered frames
Compatibility Performance Mode    Multi-display/mixed-GPU acceleration
Off                                               Teture filtering - Anisotropic sample optimization
Allow                                           Texture filtering - Negative LOD bias
Performance                                 Texture filtering - Quality
Off                                               Texture filtering - Trilinear optimization
Off                                               Threaded optimization
Off                                               Triple buffering
Off                                               Texture filtering - Anisotropic filter optimization
Force Off                                      Vertical sync

Step Two:
Spoiler: show

Right-Click On Your Neverwinter Nights Shortcut
Select  Properties
Select  Open File Location
Select  nwnplayer.ini
Select  Wordpad or Notepad To Open It
Under [Game Options] Find Client CPU Affinity
Change The Current Value to Client CPU Affinity=0
Save Any Changes Made And Close It

Step Three: (Try This Option Before The Others)
Spoiler: show

I ran the Configuration for the game, you can do this by running "nwnconfig.exe" or "nwloader.exe" located inside your Neverwinter Nights directory. If you run it by the launcher select "Configuration", afterwards click the [Change] button. Click the drop down menu under "Sound" and select "Safe Mode" then click the [Ok] button then [Accept] button.


Blacky Rose

  • Undead Slayer
  • ***
  • Posts: 218
Re: Help please - it does not run smooth
« Reply #3 on: September 15, 2011, 09:31:22 PM »
Some Nvidia's 400 and 500 series graphics cards had stuttering issues with NWN that a recent driver update fixed. It is possible that while the computer is new the drivers that come pre-installed on it aren't actually particularly recent and as such don't contain that fix. You could try updating the graphics driver.
Better to write for yourself and have no public, than to write for the public and have no self.

Avatar6666

  • Dark Power
  • ******
  • Posts: 1405
Re: Help please - it does not run smooth
« Reply #4 on: September 15, 2011, 09:44:05 PM »
Truth be told, most new pc's and Laptop's need to down load new drivers. They dont seem to care at the factory untill it hits a service pack.


“In brightest day, in blackest night,
No evil shall escape my sight
Let those who worship evil’s might,
Beware my power… Green Lantern’s light!”

Chaszmyr

  • Undead Slayer
  • ***
  • Posts: 115
Re: Help please - it does not run smooth
« Reply #5 on: September 15, 2011, 10:01:59 PM »
Some Nvidia's 400 and 500 series graphics cards had stuttering issues with NWN that a recent driver update fixed. It is possible that while the computer is new the drivers that come pre-installed on it aren't actually particularly recent and as such don't contain that fix. You could try updating the graphics driver.

I second this. This was a huge problem for a while. If the latest drivers are crap for you, I'm using 280.19 beta drivers and they're working flawlessly. I remembered not wanting to get the latest release drivers due to some problem they had. But, you should be fine with the latest release or beta.
Riccardo de Vesci - Red Vardo Traders
Taz'zyr Xorlarrin - Sorcere Graduate

DM Macabre

  • Dungeon Master
  • Dark Power
  • ******
  • Posts: 8481
Re: Help please - it does not run smooth
« Reply #6 on: September 16, 2011, 02:26:13 AM »
Thanks guys - will try that. Though I am really wondering why I am lagging on my laptop. My desktop is much slower, has less RAM and also a worse grafic card - still the game runs a lot faster there. So I am really wondering why. Browsing on the net I also found that it might be related to using several cores, but I did not find the best change I would need to make there. Experiences?

currently I run:
-: Curse of the Wolf :-
-: The Curse of von Zeklos :-

Chaszmyr

  • Undead Slayer
  • ***
  • Posts: 115
Re: Help please - it does not run smooth
« Reply #7 on: September 16, 2011, 02:45:14 AM »
Is it just NWN? NWN utilizes an old OpenGL shader that the 400 and 500 series nvidia card hardware no longer supports. Without it, anything that utilizes transparency (cloaks, robes, bows, list goes on) in NWN will annihilate your framerate. The last few nvidia driver releases add this support via software so it isn't a problem anymore, but if you have the old drivers, you still have the old problem.
Riccardo de Vesci - Red Vardo Traders
Taz'zyr Xorlarrin - Sorcere Graduate

DM Macabre

  • Dungeon Master
  • Dark Power
  • ******
  • Posts: 8481
Re: Help please - it does not run smooth
« Reply #8 on: September 16, 2011, 08:17:39 AM »
I donno. I don't play other games than nwn. :P

currently I run:
-: Curse of the Wolf :-
-: The Curse of von Zeklos :-

Forral

  • New to the Mists
  • *
  • Posts: 36
Re: Help please - it does not run smooth
« Reply #9 on: September 17, 2011, 03:09:04 AM »
Is it just NWN? NWN utilizes an old OpenGL shader that the 400 and 500 series nvidia card hardware no longer supports. Without it, anything that utilizes transparency (cloaks, robes, bows, list goes on) in NWN will annihilate your framerate. The last few nvidia driver releases add this support via software so it isn't a problem anymore, but if you have the old drivers, you still have the old problem.
Awesome! NWN has long been running so piss poor for me that doing anything beyond socializing in game has been a nightmare, and even then FPS has been uneven enough that I can't properly see what I'd been typing in anything better than a couple of second intervals. Given the issues I suffered, I just kind of stopped playing the game and amused myself with other things. I updated my GPU drivers a few days ago in an effort to defeat a frequently recurring black-screen in Dead Island (The new drivers fixed that too), so I was already sitting on the latest drivers, but I hadn't bothered testing them in NWN. Then I come to see your post here, and figure, "Hey, maybe I'll go see if there's been any improvement." Testing the game, I actually get performance that's just as good as it always used to be on my old computer. Many thanks for that comment, without it I would probably never have gotten back to NWN at all. :)

I really wish Bioware hadn't shut down their Neverwinter Nights forums. It had tons of useful stickies and frequent troubleshooting for not only the Player client but the DM one and the Toolset as well. Now these troubleshooting questions are asked all over the internet and people seem to rarely get answers at all, and when they actually do get replies they're rarely all that useful. A bloody shame. Luckily it wasn't so in this case, so thanks for unintentionally helping me out!

DM Macabre

  • Dungeon Master
  • Dark Power
  • ******
  • Posts: 8481
Re: Help please - it does not run smooth
« Reply #10 on: September 17, 2011, 04:10:05 AM »
lol I guess some parts of Bioware are really frustrated that NWN is still running and they never took money for the online service ;)

currently I run:
-: Curse of the Wolf :-
-: The Curse of von Zeklos :-

dark_majico

  • Dark Power
  • ******
  • Posts: 1551
Re: Help please - it does not run smooth
« Reply #11 on: September 17, 2011, 07:43:38 AM »
Did you solve your problems then? Is it allways choppy or just under certain conditions?
Active:
Constance Hollows