Author Topic: Neverwinter Nights and NVidia 500 Series  (Read 5627 times)

kyoung2200

  • Undead Slayer
  • ***
  • Posts: 137
Neverwinter Nights and NVidia 500 Series
« on: April 18, 2011, 12:37:50 AM »
I've heard that there are problems with this.  I myself have a 560, and upon logging in, I get 10 FPS if anyone else is around.  Anyone know of any kind of fix for this?  I can do some RP with 10 FPS, but anything that requires me doing anything other than typing is impossible.
::No longer posting under this account.  Using account named Swiftar::

Vissitude

  • Dark Lord
  • *****
  • Posts: 539
  • "Ni ceart go cur le cheile"
Re: Neverwinter Nights and NVidia 500 Series
« Reply #1 on: April 18, 2011, 01:12:51 AM »
I have the 200 series, 210 specifically, and I get the same problem. If there are a lot of people, movement is next to impossible but when its one or two people, I'm okay. Dunno any fixes, haven't found one yet at least. So, if one is found, I'd be grateful as well

"Maireann croi eadrom i bhfad"

kyoung2200

  • Undead Slayer
  • ***
  • Posts: 137
Re: Neverwinter Nights and NVidia 500 Series
« Reply #2 on: April 18, 2011, 01:54:47 AM »
http://forums.nvidia.com/index.php?showtopic=188517&st=80

Found that.  FPS is significantly better, but I'm seeing white textures.  Note that in the post it says to DISABLE the option, whereas I actually had to ENABLE it to get it to work.

I'll take being able to move around and white tables over being stuck, lagging, and wooden tables anyday.
::No longer posting under this account.  Using account named Swiftar::

Ingwulf

  • Undead Master
  • ****
  • Posts: 288
Re: Neverwinter Nights and NVidia 500 Series
« Reply #3 on: April 18, 2011, 05:24:08 AM »
I am having slow results aswell. Although only when playing on the notebook PC. Anyone else playing on a notebook?

Ingwulf Son of Bulwig
Daft The good soul
Vindur- natures explorer
Joric - Merc with no wishes

Blacky Rose

  • Undead Slayer
  • ***
  • Posts: 218
Re: Neverwinter Nights and NVidia 500 Series
« Reply #4 on: April 18, 2011, 06:44:33 AM »
http://forums.nvidia.com/index.php?showtopic=188517&st=80

Found that.  FPS is significantly better, but I'm seeing white textures.  Note that in the post it says to DISABLE the option, whereas I actually had to ENABLE it to get it to work.

I'll take being able to move around and white tables over being stuck, lagging, and wooden tables anyday.

As the original poster of the solution suggested this may be caused by .dds format textures, I suppose it may be worth to test it with a texture override mod such as NWNCQ in which the override textures already come in .tga format.
Better to write for yourself and have no public, than to write for the public and have no self.

Dhark

  • Dark Power
  • ******
  • Posts: 1143
  • Ladul !
Re: Neverwinter Nights and NVidia 500 Series
« Reply #5 on: April 18, 2011, 01:49:50 PM »
I have a 500 series & Ive tried NWNCQ once , frame rate was less than 1 .

Although the FPS slows when entering an area with lots of people , it soon picks up. What kills me is travelling with more than 3 people.

kyoung2200

  • Undead Slayer
  • ***
  • Posts: 137
Re: Neverwinter Nights and NVidia 500 Series
« Reply #6 on: April 18, 2011, 10:36:15 PM »
I have found a temporary fix, located in that same thread, that works for me and does not include any of the glitches in the previous fix.

Quote
I believe I have a workaround. Download Damian Trebilco's excellent GLIntercept. This will wrap calls to OpenGL32.dll. Copy OpenGL32.dll from the GLIntercept directory to the NWN directory. Copy gliConfig_ExtOverride.ini to the NWN directory and rename it to gliConfig.ini. Inside of the ExtensionOverride block at the bottom of the file, add the line
RemoveExtensions = (GL_NV_vertex_array_range2, GL_NV_vertex_program);

If this is not clear, you can search for the commented line
// RemoveExtensions = (GL_S3_s3tc,WGL_EXT_swap_control);

and replace it with the one I have provided above.

Removing these two extensions seems to have eliminated the problem for me. I haven't noticed any side effects as yet, but I suspect that NVIDIA's driver team could do a lot better than this hack. You can also go through and disable all of the logging functions, but I believe they are pretty minimal in that config template.
SRC: http://forums.nvidia.com/index.php?s=5b8288f8d349e40cd0faf1ec1ac0edeb&showtopic=188517&st=60

I did exactly as it said: remove the entire "// RemoveExtensions = (GL_S3_s3tc,WGL_EXT_swap_control);" line (even though its commented out), and put the line in he suggests.  No graphic tearing, no white glitches, max FPS.

Hope this helps the rest of you out who are having the same problem.
::No longer posting under this account.  Using account named Swiftar::

Honoun

  • Dark Lord
  • *****
  • Posts: 865
  • Happy Rainy Days
Re: Neverwinter Nights and NVidia 500 Series
« Reply #7 on: May 07, 2011, 02:53:41 AM »
This is an issue with all Fermi based cards, and it's a driver problem. Only reason why I haven't been logging in too much of late. Playing is too painful when the FPS drops to a crawl all the time.  :cry:

Honoun

  • Dark Lord
  • *****
  • Posts: 865
  • Happy Rainy Days
Re: Neverwinter Nights and NVidia 500 Series
« Reply #8 on: May 09, 2011, 09:45:52 PM »
Good news everyone, according to Nvidia the June driver release WILL correct the issue with slow FPS drops in all thier 400 and 500 series of cards... So start counting the days  :mrgreen:

kyoung2200

  • Undead Slayer
  • ***
  • Posts: 137
Re: Neverwinter Nights and NVidia 500 Series
« Reply #9 on: May 09, 2011, 10:30:07 PM »
Good news everyone, according to Nvidia the June driver release WILL correct the issue with slow FPS drops in all thier 400 and 500 series of cards... So start counting the days  :mrgreen:

Good news!  For now I'll enjoy the OpenGL fix
::No longer posting under this account.  Using account named Swiftar::

Budly

  • Dark Power
  • ******
  • Posts: 5948
Re: Neverwinter Nights and NVidia 500 Series
« Reply #10 on: May 10, 2011, 11:30:28 AM »
Do a Nvidia 480 count to this problem?

Honoun

  • Dark Lord
  • *****
  • Posts: 865
  • Happy Rainy Days
Re: Neverwinter Nights and NVidia 500 Series
« Reply #11 on: May 12, 2011, 04:24:35 PM »
As far as I know, yes all their 400 series and 500 series based cards had this issue. So by default the 480 would have it... But as of June, problem solved according to thier spokesman on their tech forums anyway

Budly

  • Dark Power
  • ******
  • Posts: 5948
Re: Neverwinter Nights and NVidia 500 Series
« Reply #12 on: May 12, 2011, 05:58:40 PM »
Oh wonderful!

Cause I have also noticed lag and weird sounds.

Is this fix for NWN alone? :S or many games had these problems? Just thinking, NWN dont have that many players to maybe be worth a patch! If so then nice!

Honoun

  • Dark Lord
  • *****
  • Posts: 865
  • Happy Rainy Days
Re: Neverwinter Nights and NVidia 500 Series
« Reply #13 on: May 12, 2011, 09:44:00 PM »
Actually, the issue with the drivers with the 400 and 500 based cards was wider than just NWN. It's just that the NWN community was being the most vocal about on the Nvidia forums... Well kinda, the relevant thread is 15 pages long.  ;)

Bad_Bud

  • Developers
  • Dark Power
  • *
  • Posts: 4434
Re: Neverwinter Nights and NVidia 500 Series
« Reply #14 on: May 24, 2011, 05:04:40 PM »
I have found a temporary fix, located in that same thread, that works for me and does not include any of the glitches in the previous fix.

Quote
I believe I have a workaround. Download Damian Trebilco's excellent GLIntercept. This will wrap calls to OpenGL32.dll. Copy OpenGL32.dll from the GLIntercept directory to the NWN directory. Copy gliConfig_ExtOverride.ini to the NWN directory and rename it to gliConfig.ini. Inside of the ExtensionOverride block at the bottom of the file, add the line
RemoveExtensions = (GL_NV_vertex_array_range2, GL_NV_vertex_program);

If this is not clear, you can search for the commented line
// RemoveExtensions = (GL_S3_s3tc,WGL_EXT_swap_control);

and replace it with the one I have provided above.

Removing these two extensions seems to have eliminated the problem for me. I haven't noticed any side effects as yet, but I suspect that NVIDIA's driver team could do a lot better than this hack. You can also go through and disable all of the logging functions, but I believe they are pretty minimal in that config template.
SRC: http://forums.nvidia.com/index.php?s=5b8288f8d349e40cd0faf1ec1ac0edeb&showtopic=188517&st=60

I did exactly as it said: remove the entire "// RemoveExtensions = (GL_S3_s3tc,WGL_EXT_swap_control);" line (even though its commented out), and put the line in he suggests.  No graphic tearing, no white glitches, max FPS.

Hope this helps the rest of you out who are having the same problem.

Not sure why some of you are ignoring this post!  It's not hard to do, and it does work.  Don't be scared by the fact this requires you to type in notepad.

I was running at a choppy 12-30 fps, and after this patch I am around 80-120.

FYI: My card is an NVIDIA GTX 560ti.
« Last Edit: May 24, 2011, 05:08:12 PM by Bad_Bud »


DM Tarokka

  • Dark Power
  • ******
  • Posts: 6931
  • Fata volentem ducunt, nolentem trahunt
    • Facebook page
Re: Neverwinter Nights and NVidia 500 Series
« Reply #15 on: May 26, 2011, 10:38:54 AM »
Dear Bad_Bud, anything you may know if that works also for the nvidia gtx 260?
http://www.facebook.com/CiaranII
Pokemon Go! 5688 6574 4676

Bad_Bud

  • Developers
  • Dark Power
  • *
  • Posts: 4434
Re: Neverwinter Nights and NVidia 500 Series
« Reply #16 on: May 28, 2011, 04:34:07 AM »
No, but it wouldn't hurt if you tried it.

Also, update to the latest drivers, first.


nirklars

  • New to the Mists
  • *
  • Posts: 1
Re: Neverwinter Nights and NVidia 500 Series
« Reply #17 on: June 15, 2011, 05:33:18 PM »
Thanks a lot for this tip.
I made a small install script to simplify the process.

It gives me 30-60 fps. Before applying i had 1-10 fps.

Its in no way a solution but a workaround until Nvidia fixes this problem :/

See if it works for you and please report back.
http://nwvault.ign.com/View.php?view=Other.Detail&id=1500

Best Regards
Nick