Author Topic: Neverwinter Nights On Vista (Solution)  (Read 2874 times)

Romar Notten

  • Guest
Neverwinter Nights On Vista (Solution)
« on: April 07, 2011, 10:23:38 PM »
A friend of mine whom which I play Neverwinter Nights with on server has a Vista OS and constantly experiance performance issues (lagg for short) so after browsing the web for about a hour and going by suggestions and feebacks I managed to solve his problem as how now plays without even the hint of lagg. I would suggest trying "Step Three" before the others.


Step One: (Nivida Graphics Card With Control Panel Only)
Spoiler: show

Right-Click On Your Desktop
Select  Nividia Control Panel
Select  3D Settings
Select  Manage 3D Settings
Select  Program Settings Tab
Select  Neverwinter Nights (nwnmain.exe)

Settings Listed Under (nwnmain.exe) "Suggested Changes"
Grayed Out                                  Ambient Occlusion
Off                                               Anisotropic Filtering
Off                                               Antialiasing - Gamma Correction
Off                                               Antialiasing - Mode
None                                            Antialiasing - Setting
Off                                               Antialiasing - Transparency
Use Global Setting                        CUDA - GPUs
Use Global Setting                        Maximum pre-rendered frames
Compatibility Performance Mode    Multi-display/mixed-GPU acceleration
Off                                               Teture filtering - Anisotropic sample optimization
Allow                                           Texture filtering - Negative LOD bias
Performance                                 Texture filtering - Quality
Off                                               Texture filtering - Trilinear optimization
Off                                               Threaded optimization
Off                                               Triple buffering
Off                                               Texture filtering - Anisotropic filter optimization
Force Off                                      Vertical sync

Step Two:
Spoiler: show

Right-Click On Your Neverwinter Nights Shortcut
Select  Properties
Select  Open File Location
Select  nwnplayer.ini
Select  Wordpad or Notepad To Open It
Under [Game Options] Find Client CPU Affinity
Change The Current Value to Client CPU Affinity=0
Save Any Changes Made And Close It

Step Three: (Try This Option Before The Others)
Spoiler: show

I ran the Configuration for the game, you can do this by running "nwnconfig.exe" or "nwloader.exe" located inside your Neverwinter Nights directory. If you run it by the launcher select "Configuration", afterwards click the [Change] button. Click the drop down menu under "Sound" and select "Safe Mode" then click the [Ok] button then [Accept] button.

hugolino

  • Dark Lord
  • *****
  • Posts: 528
Re: Neverwinter Nights On Vista (Solution)
« Reply #1 on: July 09, 2011, 07:33:19 PM »
Thanks for this information. I will give it a shot. :)

Chaszmyr

  • Undead Slayer
  • ***
  • Posts: 115
Re: Neverwinter Nights On Vista (Solution)
« Reply #2 on: July 18, 2011, 12:35:19 AM »
I actually have a major performance gain by making sure nwmain.exe is utilizing multiple cores. "Client CPU Affinity=0" Assures that it only uses your first core - if you want it to use all available cores, you want "Client CPU Affinity=-2" to disable that option. Big FPS boost for me.

Also, side note, nwtoolset.exe also has a similar option, and the toolset runs MUCH faster with a value of -2.
Riccardo de Vesci - Red Vardo Traders
Taz'zyr Xorlarrin - Sorcere Graduate

engelfire

  • Dark Power
  • ******
  • Posts: 1257
Re: Neverwinter Nights On Vista (Solution)
« Reply #3 on: July 18, 2011, 03:27:21 AM »
I remember there being some issues with multiple core, like it would look like characters would "lag" around when they are really not lagging at all. Might not happen to all but there are some reports of that.

On my old machine i had Vista and i could run nwn smoothly when i put it to XP compatibility mode, and on top of that i put it to run as administrator. And on top of those i made it start as 640x480 resolution because i crashed on the opening titles and that resolution fixed the problem.
Vino - Who are you calling fat !?
Hekathn - You make a fine collection of bodyparts nnggghhh...

Chaszmyr

  • Undead Slayer
  • ***
  • Posts: 115
Re: Neverwinter Nights On Vista (Solution)
« Reply #4 on: July 18, 2011, 06:50:10 PM »
That is really weird. If it was the intro movies itself doing that, you can turn those off in nwn.ini by setting Disable Intro Movies to 1 ( Disable Intro Movies=1 ) under [Config]. If it isn't there, add it on the last line before [Video Options]. I use a shortcut on my desktop directly to Ravenloft though, so I don't deal with those shenannigans D:
Riccardo de Vesci - Red Vardo Traders
Taz'zyr Xorlarrin - Sorcere Graduate