Author Topic: Crashing.  (Read 831 times)

DM Tarokka

  • Dark Power
  • ******
  • Posts: 6931
  • Fata volentem ducunt, nolentem trahunt
    • Facebook page
Crashing.
« on: May 23, 2010, 07:31:07 AM »
I suffer from repeated crashes of NWN in the area close to the palace of dwarves. This happens when I go in with Win7, if I restart the system in winXp the problem disappeares. Any clues?
http://www.facebook.com/CiaranII
Pokemon Go! 5688 6574 4676

dark_majico

  • Dark Power
  • ******
  • Posts: 1551
Re: Crashing.
« Reply #1 on: May 23, 2010, 08:53:34 AM »
I have a bit of an issue with windows7 and nwn in general. I recently added the command line for max memory usage to my nwnplayer.ini file. Apparently nwn uses a default 16 meg of mem, if you increase this it eases the strain on your computer. The feature was put in in 1.69 update but its not done automaticly so you have to add in the line yourself under [game options]

'Max Memory Usage=XXX'

XXX being the number you want, there is apparently a limit so they say there is no use putting a gigs worth in there, dont add too much of a figure because if you put in a higher figure than spare memory you have it will default back to the origional setting, and its in mb I think thats the right denomination (is that the right word?)

Might help you out.
Active:
Constance Hollows

DM Tarokka

  • Dark Power
  • ******
  • Posts: 6931
  • Fata volentem ducunt, nolentem trahunt
    • Facebook page
Re: Crashing.
« Reply #2 on: May 23, 2010, 09:22:44 AM »
What value should I set? And have to add that string anyway?
http://www.facebook.com/CiaranII
Pokemon Go! 5688 6574 4676

dark_majico

  • Dark Power
  • ******
  • Posts: 1551
Re: Crashing.
« Reply #3 on: May 25, 2010, 11:30:57 AM »
Well I have the value set at 128 meaning 128meg. Exactly what to set it too is a bit up in the air because bioware said in there official testing that values over 64 had little to no affect, but they said this was a test ran on the single player campaingn and custom modules may differ, they didnt say why though. So if anyone can think of a reason why it would that would be helpfull. Yes you have to add that command line in, just add it to the top of the nwnplayer.ini file under game options, dont include quotes.

So somewhere between 64 and 128 should do the trick. Try 64 and see if performance improves. I dont crash all that much anyway but since changing it a few days ago I have only crashed once, I cant say for certain this is giving me any benefit yet though.
« Last Edit: May 25, 2010, 11:33:54 AM by dark_majico »
Active:
Constance Hollows