You have been taken by the Mists

Author Topic: Fedora 13 + Neverwinter Nights = Baaaaaaad  (Read 2295 times)

bloodandsoil

  • Undead Slayer
  • ***
  • Posts: 245
    • TWAJ
Fedora 13 + Neverwinter Nights = Baaaaaaad
« on: May 19, 2010, 02:46:18 AM »
Getting a constant 99.7% CPU utilization (I have an Intel Core 2 Duo E6600)

Getting a crazy memory leak (I have 4GB of memory).  In about 5 minutes on the server the memory utilization was at 77.1% and climbing fast.

No clue what the problem is.  I bet it works fine in Windows.


HELL TAKES THE HINDMOST

Axel

  • Eternal Saviour/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 1530
Re: Fedora 13 + Neverwinter Nights = Baaaaaaad
« Reply #1 on: May 19, 2010, 05:31:19 AM »
Were you running a dedicated server or a client on your machine?

bloodandsoil

  • Undead Slayer
  • ***
  • Posts: 245
    • TWAJ
Re: Fedora 13 + Neverwinter Nights = Baaaaaaad
« Reply #2 on: May 19, 2010, 07:30:01 AM »
No server.  Just the one client process.

HELL TAKES THE HINDMOST

Axel

  • Eternal Saviour/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 1530
Re: Fedora 13 + Neverwinter Nights = Baaaaaaad
« Reply #3 on: May 19, 2010, 09:28:07 AM »
Hmm.. that sounds strange. Do you have the same problem running the single player campaign?

bloodandsoil

  • Undead Slayer
  • ***
  • Posts: 245
    • TWAJ
Re: Fedora 13 + Neverwinter Nights = Baaaaaaad
« Reply #4 on: June 02, 2010, 08:29:04 PM »
Yes same problem running the single player campaign.  In fact the problem arises even at the initial menu screen.

I am gonna do a clean install of NWN from scratch.  Maybe that will cause the problem to go away.

What is the correct CEP version to download by the way?  Is the "CEP 2.3c at NWVault" link on the Downloads page still correct?
« Last Edit: June 02, 2010, 11:30:41 PM by bloodandsoil »

HELL TAKES THE HINDMOST

bloodandsoil

  • Undead Slayer
  • ***
  • Posts: 245
    • TWAJ
Re: Fedora 13 + Neverwinter Nights = Baaaaaaad
« Reply #5 on: June 02, 2010, 10:55:03 PM »
Just re-downloaded and installed everything fresh.  I didn't put in any of the optional Ravenloft stuff, just the hak files and the tlk file.  Seeing same problem.  Game hovers around 95-97% CPU utilization and is grabbing memoy like crazy (45% after idling for about 5 mins).

I tried disabling the games SDL library and using the one from my system (by editing the nwn file and changing to "export LD_LIBRARY_PATH=./miles:$LD_LIBRARY_PATH").  Same problem still happens.

Besides upgrading to Fedora 13 (from 12) I also switched computers.  I had been on a system with an Nvidia 8800 GTS, but now I have an ATI Radeon HD 4850.

I might try running Windows XP as a guest operating system and see how that works out...
« Last Edit: June 02, 2010, 11:29:26 PM by bloodandsoil »

HELL TAKES THE HINDMOST

Cebrimal

  • New to the Mists
  • *
  • Posts: 25
Re: Fedora 13 + Neverwinter Nights = Baaaaaaad
« Reply #6 on: July 04, 2010, 12:19:23 AM »
I know in past (not sure about present) ATI has offered poor support for video cards in linux.  Have you made sure you are running the latest restricted drivers?  Or have you tried any previous driver packages?  Is there any chance of swapping out the old video card to eliminate this option?