You have been taken by the Mists

Author Topic: running choppy  (Read 4421 times)

Romar Notten

  • Guest
Re: running choppy
« Reply #25 on: May 13, 2012, 12:15:03 PM »
The listed solutions below is what I have done for a friend that used to play Neverwinter on Windows Vista which afterwards his play went from choppy to smooth. However I'm unsure how it would work with Windows 7 but it still should could still be a possible solution if you wanted to try it.

Roll Back Driver  (Use At Your Own Risk)
Spoiler: show


Windows Xp (Click Start, Click Run)
*Copy this:  devmgmt.msc
*Highlight Text And Press: Ctrl+C (Copy)
*To Paste The Text: Ctrl+V (Paste)
*Paste It Into Run, Then Click Ok

Windows Vista/ Windows 7 (Click Start)
*Copy this:  devmgmt.msc
*Highlight Text And Press: Ctrl+C (Copy)
*To Paste The Text: Ctrl+V (Paste)
*Paste It Into The Search Box, Press Enter Key

Click The "+" Sign Next To Display Adapters
*Look For Your Video Card Name
*Example Video Card Name: NVIDIA GeForce4 MX 440

Double Click The Video Card
*Select The Tab: Driver
*Select Roll Back Driver

**Have Your Video Card Driver On Hand Just In Case, Either By Disc Or Downloaded Driver**



Solution One
Spoiler: show


Open Up Your NWN Directory
*Right-Click On Your NWN Shortcut, Properties, Find Target (Win Xp)
*Right-Click On Your NWN Shortcut, Properties, Open File Location (Win Vista / Win 7)

Open The File Called, Nwnplayer.ini
*Open The File Using Wordpad, Notepad Or Something Similar.

Under [Game Options] Locate. Client CPU Affinity=
*To Easily Find It Use Your Search Function, Normally Set As Ctrl+F

Edit Client CPU Affinity=
*Change The Value To Either Be 0 Or 1
*Should Look Like This: Client CPU Affinity=0
*Should Look Like This: Client CPU Affinity=1
*Save Changes Then Check Your Game



Solution Two
Spoiler: show


Open Up Your NWN Directory
*Right-Click On Your NWN Shortcut, Properties, Find Target (Win Xp)
*Right-Click On Your NWN Shortcut, Properties, Open File Location (Win Vista / Win 7)

Run The Program Called NwnConfig.exe
*Confiquration Settings

Click The Change Button
*Click The Drop Down Menu Next To Sound
*Select Safe Mode
*Save Changes Then Check Your Game

As A Side Note
*Sometimes Your Correct Processor Or Graphic Isn't Listed Correctly In Nwconfig.ini
*Using The Scan Can Correct This
*If It Doesn't Correct It, You Can Simply Delete Nwconfig.ini Or Move It, Then Run The Scan Again



Solution Three
Spoiler: show


Graphic Card Control Panel
*I Can't Get Into Detail On How To Open This Open, Varies With Different Cards

To Standardly Open Your Video Card Control Panel
*Click "Start", "Control Panel"
*Find The Control Panel For Your Video Card
*Mine is "Nivida Control Panel"

Once You Have Ran Your Control Panel
*You Want To Access Your 3D Settings                         (Varies With Different Video Cards)
*Under Sub Menu's For This Click "Manage 3D Settings" (Varies With Different Video Cards)

You Then Want To Access "Program Settings"
*Should Be Listed As Possible Tab Box Located Near "Global Settings" In The Main Window

Program Settings (Neverwinter Nights)
*Click "Add" Button And Browse To Your NWN Directory And Select: Nwnmain.exe
*You Will See A Assorment Of Details Once Added

Settings Listed Under (nwnmain.exe
*Suggested Changes
*Some Video Cards May Display More Options Or Less Options

Setting                                         Feature
--------------------------------------------------------------------------------------------------------------------------
Grayed Out                                  Ambient Occlusion
Off                                               Anisotropic Filtering
Off                                               Antialiasing - Gamma Correction
Off                                               Antialiasing - Mode
None                                            Antialiasing - Setting
Off                                               Antialiasing - Transparency
Use Global Setting                        CUDA - GPUs
Use Global Setting                        Maximum pre-rendered frames
Compatibility Performance Mode    Multi-display/mixed-GPU acceleration
Off                                               Teture filtering - Anisotropic sample optimization
Allow                                           Texture filtering - Negative LOD bias
Performance                                 Texture filtering - Quality
Off                                               Texture filtering - Trilinear optimization
Off                                               Threaded optimization
Off                                               Triple buffering
Off                                               Texture filtering - Anisotropic filter optimization
Force Off                                      Vertical sync



Solution Four
Spoiler: show


Open The Properties For Your Neverwinter Shortcut
*Right-Click Your Neverwinter Nights Shortcut
*Select Properties

Editing the Properties
*Look Around And Change It To Either One Of, Or Both Of The Following
*Run as Administrator, either by drop down menu or a check box depending on windows version
*Compatibility Mode, Something Windows Xp Related Should Work
*Click Ok, Close Out The Window And Check Your Game.


« Last Edit: May 13, 2012, 12:28:39 PM by Romar Notten »

Heretic

  • Dungeon Master &
  • Dark Power
  • ******
  • Posts: 16951
Re: running choppy
« Reply #26 on: May 13, 2012, 01:14:38 PM »
Thanks a lot guys, gonna try all of the above and see what happens.  :)

Heretic

  • Dungeon Master &
  • Dark Power
  • ******
  • Posts: 16951
Re: running choppy
« Reply #27 on: May 13, 2012, 01:58:03 PM »
The solution was rolling back the driver.

Using a 11 driver, the 12 messed me up big time.


Thanks guys. :)

Jeebs

  • Dark Lord
  • *****
  • Posts: 940
Re: running choppy
« Reply #28 on: May 13, 2012, 02:52:34 PM »
The solution was rolling back the driver.

Using a 11 driver, the 12 messed me up big time.


Thanks guys. :)

Yeah, isn't it odd how newer versions of things can break stuff? Also, your first mistake was getting a Radeon  ;)  Though it seems a fair bit of people are having issues with lag these days. I'm not quite sure what's causing it anymore, as most of them insist it's not hardware related.

Geiger

  • Guest
Re: running choppy
« Reply #29 on: May 13, 2012, 02:57:09 PM »
Mine wasn't - since this restart I'm 100% fine. But I have a feeling it'll happen again.

Jeebs

  • Dark Lord
  • *****
  • Posts: 940
Re: running choppy
« Reply #30 on: May 13, 2012, 03:12:41 PM »
Mine wasn't - since this restart I'm 100% fine. But I have a feeling it'll happen again.

It always does. Your computer starts acting strangely if you leave it on all the time and never restart it. Things start taking longer to load, errors crop up for no apparent reason and well, long story short, even if you have your system on all the time, you need to reboot it once in a while to keep it running somewhat smoothly. This is less of an issue on a Linux-based system from what I've seen, but for something like the PotM server, you have to keep in mind that it's keeping track of a lot of information. All the corpses on the ground, the items in said corpses, all the non-standard items you can find in a shop after PCs have sold the loot from their adventures, etc. The more stuff the server has to keep track of, the less processing power/memory it has available to handle all the information from players. That's why we have DMs reset it. One thing they could do, although I'm not sure how to set this up myself, is set up the server to self-reboot every 8 or 12 hours. I've seen other servers use this, it would start warning you an hour ahead that it would restart itself and then do the whole thing automatically. How you get that to work with NWN so the actual system doesn't just do a reboot without warning is not something I know how to do though, so it's something for the devs to consider and look into if they choose to go that route.

dark_majico

  • Dark Power
  • ******
  • Posts: 1551
Re: running choppy
« Reply #31 on: May 14, 2012, 02:49:50 AM »
I updated windows 7, which I had not done in a long time. Same with my Radeon ATI 6900 video cards' driver and what a mistake that was. :S

Catalyst 12 series breaks NWN a little, the easiest solution may be just going with 11 series for the time being.

Alternatively also disabling 'surface optimization' for the NWN application in the catalyst control center allegedly fixes it.

I went looking for that option in my catalyst control centre and I dont see it, did you mean something else Rose? I had a problem with series 12, then i rolled back to 11, but then I updated again to  12 and the problem went away. Might be something to do with installing new updates without doing a clean uninstall or something. Im glad thats fixed though and I dont have to keep dismissing the update reccomendation.

I also had a problem with choppy gameplay a long time ago whenever I entered combat mode, it turns out my sound options in thw game menu had switched to Realtek Audio, I dont even know what Realtek is, let alone if I have it or not, I changed it to one of the other options and problem solved.
Active:
Constance Hollows

Jeebs

  • Dark Lord
  • *****
  • Posts: 940
Re: running choppy
« Reply #32 on: May 14, 2012, 12:35:58 PM »
Realtek is your onboard sound... basically the one built into the motherboard. I find it weird that it's causing issues for people though. I stopped using sound cards two PCs ago when I realized that the onboard sound was usually just as good these days.  I suppose it's dependent on how much RAM and processing power you have then, 'cause I don't usually have any issues.

dark_majico

  • Dark Power
  • ******
  • Posts: 1551
Re: running choppy
« Reply #33 on: May 15, 2012, 02:53:25 AM »
Realtek is your onboard sound... basically the one built into the motherboard. I find it weird that it's causing issues for people though. I stopped using sound cards two PCs ago when I realized that the onboard sound was usually just as good these days.  I suppose it's dependent on how much RAM and processing power you have then, 'cause I don't usually have any issues.

I have a quad core 2.5 gig processor and 3 gig of ram, it has nothing to do with that, its just Neverwinter Nights ghayness thats all :P
Active:
Constance Hollows