You have been taken by the Mists

Author Topic: CPU Issue with NWN on XP  (Read 1920 times)

tears_of_elysium

  • Outlander
  • **
  • Posts: 96
  • Waiting, Watching, Slowly Taking Form
CPU Issue with NWN on XP
« on: March 23, 2010, 07:41:41 AM »
Hi guys! I have heaps of candy for anybody who can help me... I just recently purchased a compy on Ebay (yes I was that desperate)... it's old, and I don't expect it to work wonders, but when I load up NWN the thing goes so laggy... it is nearly a frame by frame in NWN, on the lowest possible settings...

The CPU reads at 100%, which I know is normal for many games, but I don't understand why the computer is being sooo laggy. It's a Pentium 4 with 2.7ghz single core processor, 1.5 GB of RAM, and yup. It is driving me crazy!

Purist

  • Vallaki Guards
  • Dark Power
  • ******
  • Posts: 1729
Re: CPU Issue with NWN on XP
« Reply #1 on: March 23, 2010, 09:16:43 AM »
I got an Athlon XP 3000+ and whilst playing NWN my CPU always stays at 100% no matter what. Same on the tool set within an area of 4x4 and even on the PC proprieties screen(only the character standing and bouncing, background frozen).

You can't do anything other than select "2D Miles Emulated AudioWhatever" as audio render and lowering graphics, such as animated water/lava and such.  

The right option is to get a Dual Core or better processor, yes, that means 80% the parts you own renewed.

tears_of_elysium

  • Outlander
  • **
  • Posts: 96
  • Waiting, Watching, Slowly Taking Form
Re: CPU Issue with NWN on XP
« Reply #2 on: March 23, 2010, 04:23:45 PM »
But I don't understand, I've played NWN successfully on a computer older than this, is there not some setting or something which I can turn down to get this to run properly?

DM Nocturne

  • Sanguis Noctis
  • Dark Power
  • ******
  • Posts: 3262
  • Vampires don't do dishes
Re: CPU Issue with NWN on XP
« Reply #3 on: March 23, 2010, 04:35:00 PM »
Neverwinter Nights worked on my computer with a single core. The only thing I needed to consider was having the right driver for my graphics card, so perhaps there lies your solution - update your graphics drivers.

Badbelly

  • Undead Slayer
  • ***
  • Posts: 229
  • RP imposter
Re: CPU Issue with NWN on XP
« Reply #4 on: March 23, 2010, 06:00:45 PM »
Sorry you're having problems gettin that rig workin. My computer is ancient too, so I feel your pain.
Here is my recommendation.. Start by making sure Vertical Sync is disabled on your graphics card, this is a cause of loss of frame rate in games. Test after making change and see if you notice an improvement. Next, turn all in game graphics/effects off or to the lowest possible setting. Test after making change and see if you notice an improvement. If  performance still sucks, lower resolution until frame rate is acceptable. After you get frame rate at an acceptable level, start adding some of the graphics/effects back in one at a time, taking note of any drop in frame rate. This should get you up and running , if not.... blame EO.

Minstrel

  • Official Mascot of the
  • Dark Power
  • ******
  • Posts: 2044
  • Cat in the Hat
Re: CPU Issue with NWN on XP
« Reply #5 on: March 23, 2010, 08:57:44 PM »
I think it's a problem with NWN and dual-cores. Even with lowest settings I have the same problem.

My machine isn't a megalith, but I picked up Left 4 Dead at the request of three mates and that played fine on average settings, and is much more graphically intense. My CPU was generally at around 70-80% and my framerate around 25.

I go on NWN, wham, 100% and my fan goes into overdrive.

If anyone has a solution, please tell!

Purist

  • Vallaki Guards
  • Dark Power
  • ******
  • Posts: 1729
Re: CPU Issue with NWN on XP
« Reply #6 on: March 23, 2010, 09:45:26 PM »
Disabling the Skies Boxes GREATLY raise my FPS.

DM Nocturne

  • Sanguis Noctis
  • Dark Power
  • ******
  • Posts: 3262
  • Vampires don't do dishes
Re: CPU Issue with NWN on XP
« Reply #7 on: March 23, 2010, 10:01:18 PM »

tears_of_elysium

  • Outlander
  • **
  • Posts: 96
  • Waiting, Watching, Slowly Taking Form
Re: CPU Issue with NWN on XP
« Reply #8 on: March 24, 2010, 12:27:10 AM »
i suspect the issue lies with my Graphics drivers. I bought this computer from a clean format, and last night downloaded a driver detective program which pointed out about 12 of  my devices without correct or updated drivers, including my Geforce 5200FX.

Thank you Acid Zealot, I will repay you with, um... my eternal gratitude?

Avatar6666

  • Dark Power
  • ******
  • Posts: 1405
Re: CPU Issue with NWN on XP
« Reply #9 on: March 24, 2010, 02:48:00 AM »
If you have multiple processors you can set the afinity of the game to run on the one that is not working that much and increase the speed of the game. Its easy just google set afinity of a processor.


“In brightest day, in blackest night,
No evil shall escape my sight
Let those who worship evil’s might,
Beware my power… Green Lantern’s light!”

NightShadow

  • Outlander
  • **
  • Posts: 77
Re: CPU Issue with NWN on XP
« Reply #10 on: March 25, 2010, 04:49:03 AM »
A few things which you can disable/change to make things go quicker and make it easier on a computer, though you already have everything turned down, I'm just throwing these out for everyone:
First of all, disable shiny water, never use it, ever, there are so many glitches, both minor and serious, which are caused by it, including random teleporting, game crashing, and file corruption.
Sky boxes are also something which can be turned off if you're having problems, it will help a lot if you've a weaker computer.
With shadows and grass, it is sometimes best to leave them turned off or at their minimum setting, especially when there are a lot of people/monsters nearby, and environment shadows also uses a lot.
Press alt+enter to exit fullscreen mode (Not sure if you can do this without altering a file), and play at a lower resolution, this works wonders on weaker computers, and I do it with some of the more graphically intense games that my older computer simply cannot handle, like Unreal Tournament.

And finally, something which helps quite a bit, open up nwnplayer.ini in notepad, and at the end of the list in Game Options, add in a new line that reads Max Memory Usage=##, put in a number for the amount of megs you want it to have. I've had it at 64 for a while, as that's what the place I found this tweak at said was the max you could set it to, but now I've found folks setting it to 500+, so I'm at 512 right now, though I can't really test out how good it will be until next week...
Far better it is to dare mighty things, to win glorious triumphs, even though checkered by failure, than to rank with those poor spirits who neither enjoy much nor suffer much, because they live in the gray twilight that knows not victory nor defeat.