You have been taken by the Mists

Author Topic: "Twitch" and Lag  (Read 5139 times)

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
"Twitch" and Lag
« on: January 14, 2010, 06:42:06 PM »
Okays...

I am on a Pentium 4 processor with a GeForce 6600 graphic card with 2 gig RAM for now...

Everything runs smoothly but not NWN 1.

The problem be that my character twitch when walking and running and there also have some lag trouble even though i for now even run NWN on low graphic settings.
I have also noticed that sometimes Robes and cloaks on my characters and sometime actually the whole character seems to be concealed as it looks by the spell from improved invisibility, sometimes whole robes be missing.

I have checked my graphic card settings, I have updated the driverutines to it and even tried an old one, also made sure no other program be up and running that would disturb NWN.. I can not find out what the problem be here so if anyone can help with that "twitch" and lag or the concealment of clothings and even some looks on weapons i would be most greatfull.

Heard something about a character hak that was to help but could not find or locate such in the NWN vaults, maybe someone of you heard or know of that?

Thanks//Ash


LawfulJoe

  • "Evil is a thing of perception, it depends on which end of the sword you're on"
  • Dark Power
  • ******
  • Posts: 3248
  • aka AwfulJoe
    • Joe Kellerman - Graphic Artist
Re: "Twitch" and Lag
« Reply #1 on: January 14, 2010, 06:49:17 PM »
Might be connection issues? Try running a spyware search, clean out your computer of bug, viruses etc. See if it is interfering with your internet connection by hogging the line with spyware. Past that... I have no idea.

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #2 on: January 14, 2010, 06:54:41 PM »
Nothing be interfering with my internet connection or anything such.

Purist

  • Vallaki Guards
  • Dark Power
  • ******
  • Posts: 1724
Re: "Twitch" and Lag
« Reply #3 on: January 14, 2010, 07:14:46 PM »
Thats is a "old model", if you have it for quite a while, let's say, more than 2 or 3 years, you may expect that it has given all it could to run your games swell, but now it is the time for it to rest.

I bought a AGP Radeon HD 3850 512 DDR3, if I remember right. It wasn't that expensive, it indeed gave me some FPS gain, I must say it "lifted" my system up. But still, there is my Athlon XP +3000, nicknamed bottleneck, and my dear pairs of 1GB DDR 400. Been thinking about getting, temporally, a AsRock, as it has support to AGP, DDR2 and dual cores. Maybe extend even further my system until I raise the sum to pwn any Allienware on the market. *Muses*
« Last Edit: January 14, 2010, 07:16:20 PM by Purist »

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #4 on: January 14, 2010, 07:26:07 PM »
Thats is a "old model", if you have it for quite a while, let's say, more than 2 or 3 years, you may expect that it has given all it could to run your games swell, but now it is the time for it to rest.

I bought a AGP Radeon HD 3850 512 DDR3, if I remember right. It wasn't that expensive, it indeed gave me some FPS gain, I must say it "lifted" my system up. But still, there is my Athlon XP +3000, nicknamed bottleneck, and my dear pairs of 1GB DDR 400. Been thinking about getting, temporally, a AsRock, as it has support to AGP, DDR2 and dual cores. Maybe extend even further my system until I raise the sum to pwn any Allienware on the market. *Muses*

Even if the computer and the graphic card is 2 years old it have not been even used before, and compared to my old computer that ran NWN smoothly before its RAM did break this computer is far better and both computer and graphic card should be more then enough to run NWN smoothly...

I do think it have something with the graphic settings or maybe CEP to do as some items such as weapons looks odd in colour and as i mentioned when i rotate the camera..in some angels parts of my character looks as it was concealed, that also be on other characters around, the lag i suffered got even worse in closecombat with a few Skelly's.
Again, all help is welcomed and also info on that character hak pack i heard bout.

Thanks again

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #5 on: January 14, 2010, 08:48:15 PM »
The concealment problem now seems gone after even more work with the settings, though the lag remains and also that twitching the character have when moving, even if he just spins on the spot...
There seems not to be any connection problems with internet or the server either.
Also, that twitching and lag be there even in single player game.

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: "Twitch" and Lag
« Reply #6 on: January 14, 2010, 08:53:54 PM »

Bluebomber4evr: The Justice, not you, since 2002

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #7 on: January 14, 2010, 09:27:55 PM »
Checked them settings  Blue, also have a Pentium 4 processor and no multi core processor.

The lag and twitchy moments only effects me and them around me moves smooth and fine, it all starts when i self start moving.
Have also checked the framerates and them also be just fine.
Can also add here that in close combat with a few enemies the lag gets worse.

Also as mentioned in that thread by blue i have tried to go back to base settings of the graphic card with no help at all.
Also tried it when shut the V-sync of.

Ideas be welcomed here as i soon be totally out of options and ideas.
« Last Edit: January 14, 2010, 09:30:46 PM by Metal_ash »

DM Nocturne

  • Sanguis Noctis
  • Dark Power
  • ******
  • Posts: 3262
  • Vampires don't do dishes
Re: "Twitch" and Lag
« Reply #8 on: January 14, 2010, 09:49:48 PM »
Try...

Reinstalling NwN;
Redownloading and installing CEP;
Deleting your override directory and/or starting again;
Reverting back to an older graphics driver version.

Purist

  • Vallaki Guards
  • Dark Power
  • ******
  • Posts: 1724
Re: "Twitch" and Lag
« Reply #9 on: January 14, 2010, 11:29:29 PM »
Isn't there a topic about the samething around? I sweat I remember somebody complaining about this same kind of lag.

Edit: Here: http://www.nwnravenloft.com/forum/index.php?topic=19009.0

At least turning the V-Sync off solved his case.
« Last Edit: January 14, 2010, 11:33:20 PM by Purist »

Bad_Bud

  • Developers
  • Dark Power
  • *
  • Posts: 4434
Re: "Twitch" and Lag
« Reply #10 on: January 15, 2010, 01:03:51 AM »
I'm going to stab blindly here, so don't take this too seriously because I don't know a lot about what I'm talking about...

Most single core processors these days, I believe, utilize a technology that mimics multiple processors.  Intel's version is called Hyper-Threading.  I wouldn't know if this would show up on the task manager as a second processor or not, since I've never had one, but I'm going to assume it wouldn't.  That said, it could be possible that your processor is attempting to Hyper-Thread NWN.  If you can't figure this problem out, I'd suggest trying to find a way to disable Hyper-Threading to see if that clears up the problem.

Just a random guess, but probably worth a shot.


Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #11 on: January 15, 2010, 01:47:48 AM »
Try...

Reinstalling NwN;
Redownloading and installing CEP;
Deleting your override directory and/or starting again;
Reverting back to an older graphics driver version.

Done, though the problem remains.

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #12 on: January 15, 2010, 01:48:53 AM »
I'm going to stab blindly here, so don't take this too seriously because I don't know a lot about what I'm talking about...

Most single core processors these days, I believe, utilize a technology that mimics multiple processors.  Intel's version is called Hyper-Threading.  I wouldn't know if this would show up on the task manager as a second processor or not, since I've never had one, but I'm going to assume it wouldn't.  That said, it could be possible that your processor is attempting to Hyper-Thread NWN.  If you can't figure this problem out, I'd suggest trying to find a way to disable Hyper-Threading to see if that clears up the problem.

Just a random guess, but probably worth a shot.

Will give this a try, if i only can find out how to check this and also if i do have Hyper-Threading, how to turn it of.

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #13 on: January 15, 2010, 04:22:06 AM »
Okays, for now NWN runs smoothly :D after tried it all it showed to be sound settings that caused the lag and twitch. Both settings in game and my sound card setting.

BIG thanks to all that have aided me here and taken their time!

Zarathustra217

  • Lead director, main scripter, nutty geek, Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 12676
  • a.k.a. Søren
Re: "Twitch" and Lag
« Reply #14 on: January 15, 2010, 06:37:41 AM »
Most single core processors these days, I believe, utilize a technology that mimics multiple processors.  Intel's version is called Hyper-Threading.  I wouldn't know if this would show up on the task manager as a second processor or not, since I've never had one, but I'm going to assume it wouldn't. 

... they do show up:



Muhahah! :twisted:


Purist

  • Vallaki Guards
  • Dark Power
  • ******
  • Posts: 1724
Re: "Twitch" and Lag
« Reply #15 on: January 15, 2010, 09:42:25 AM »
Most single core processors these days, I believe, utilize a technology that mimics multiple processors.  Intel's version is called Hyper-Threading.  I wouldn't know if this would show up on the task manager as a second processor or not, since I've never had one, but I'm going to assume it wouldn't. 

... they do show up:



Muhahah! :twisted:



Don't make me hate you.

DM Tarokka

  • Dark Power
  • ******
  • Posts: 6931
  • Fata volentem ducunt, nolentem trahunt
    • Facebook page
Re: "Twitch" and Lag
« Reply #16 on: January 15, 2010, 10:11:35 AM »
Okays, for now NWN runs smoothly :D after tried it all it showed to be sound settings that caused the lag and twitch. Both settings in game and my sound card setting.

BIG thanks to all that have aided me here and taken their time!

Can you tell me about sound settings? Probably it is the same problem -I- have...
http://www.facebook.com/CiaranII
Pokemon Go! 5688 6574 4676

Metal_ash

  • Dark Lord
  • *****
  • Posts: 871
Re: "Twitch" and Lag
« Reply #17 on: January 16, 2010, 02:50:58 AM »
In NWN i have none of them soundsettings activated, i empty all them boxes there.
Then in advance sound options i did go for - Miles Fast 2D Positional Audio.

That's when all the lag went away, after that i have tried a few other settings to.

The % of music and such seems not to matter at all anyways so them i have on 100%.