Author Topic: Game auto minimizes and I don't know why?  (Read 5003 times)

Honoun

  • Dark Lord
  • *****
  • Posts: 865
  • Happy Rainy Days
Game auto minimizes and I don't know why?
« on: November 25, 2009, 07:03:02 AM »
Hi there, been having an issue lately and I don't know why. But when playing PotM every now and then my Desktop will pop up and the game minimizes down to my task bar. I either have to restart the game or keep maximizing the game again over and over a few times before I can play as the interface seems to freeze on me. That is to say I can't click on anything but otherwise the game keeps running as normal.

This issue isn't really that much a problem as it happens say every twenty minutes, give or take ten. And after a while seems to stop. Though I haven't played for an extended period to test that theory out yet. Still, when it does happen it's up to a minute or two before I can respond to any game play.

Has anybody else had this issue and know of what is causing it?

I'm running XP at the moment and this glitch first started to occur about two weeks ago.

Budly

  • Dark Power
  • ******
  • Posts: 5948
Re: Game auto minimizes and I don't know why?
« Reply #1 on: November 25, 2009, 07:09:14 AM »
You tried a virus skin? And of course scan with some addaware or siimilar too! Might be some annoying spyware or similar screwing around. They can do the weirdest of things.

Honoun

  • Dark Lord
  • *****
  • Posts: 865
  • Happy Rainy Days
Re: Game auto minimizes and I don't know why?
« Reply #2 on: November 25, 2009, 07:16:08 AM »
Virus scan yes, my system does an upadte and scan everynight while I sleep... However, spyware... Hadn't thought about that... I'll run updates and then scan. Let you know how it goes.

Budly

  • Dark Power
  • ******
  • Posts: 5948
Re: Game auto minimizes and I don't know why?
« Reply #3 on: November 25, 2009, 09:42:01 AM »
Virus scan yes, my system does an upadte and scan everynight while I sleep... However, spyware... Hadn't thought about that... I'll run updates and then scan. Let you know how it goes.

Sounds good! :D

You should be able to remove em with the scanner I believe :D

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: Game auto minimizes and I don't know why?
« Reply #4 on: November 25, 2009, 11:54:28 AM »
I've been having problems with this lately too. I have no viruses or spyware on my computer (I'm pretty diligent about that stuff) and now that I know it's happening to other people makes me wonder if some windows update may have broken something--as a note, this isn't just NWN that does it, every one of my programs loses focus: Firefox, MSN Messenger, Windows Media Player, etc.

Bluebomber4evr: The Justice, not you, since 2002

Bad_Bud

  • Developers
  • Dark Power
  • *
  • Posts: 4434
Re: Game auto minimizes and I don't know why?
« Reply #5 on: November 25, 2009, 12:05:44 PM »
When the interface freezes:

Maximize the game and click on the screen to make sure it's the active window.  Then hit ctrl+enter, which should bring the game into windowed mode.  Hit ctrl+enter one more time and you should be maximized and able to click things again.

That is, assuming you have windowed mode enabled for use.  I don't remember if you have to do that or not.


ThAnswr

  • Dark Power
  • ******
  • Posts: 3045
  • We all end up the same: Level 20 or dead.
Re: Game auto minimizes and I don't know why?
« Reply #6 on: November 25, 2009, 12:07:17 PM »
Same problem here with NWN.   

Personally, I think the machines are fighting back.   ;)

Try running this program.  It helped get rid of some of the most insidious viruses Symantec and McAffee don't even touch.

http://www.malwarebytes.org/mbam.php
Sig by Garison



When the going gets weird, the weird turn pro.
Hunter Thompson

"Rock is overpowered, paper is just about right" - Scissors
Thanks Aahz

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: Game auto minimizes and I don't know why?
« Reply #7 on: November 25, 2009, 12:36:27 PM »
I don't run NWN in windowed mode. Like I said, it's doing it for all my programs, not just NWN.

I run malwarebytes regularly too and didn't find anything.

Bluebomber4evr: The Justice, not you, since 2002

ThAnswr

  • Dark Power
  • ******
  • Posts: 3045
  • We all end up the same: Level 20 or dead.
Re: Game auto minimizes and I don't know why?
« Reply #8 on: November 25, 2009, 03:51:40 PM »
I don't run NWN in windowed mode. Like I said, it's doing it for all my programs, not just NWN.

I run malwarebytes regularly too and didn't find anything.

You're screwed.   :lol:
Sig by Garison



When the going gets weird, the weird turn pro.
Hunter Thompson

"Rock is overpowered, paper is just about right" - Scissors
Thanks Aahz

DM Nocturne

  • Sanguis Noctis
  • Dark Power
  • ******
  • Posts: 3262
  • Vampires don't do dishes
Re: Game auto minimizes and I don't know why?
« Reply #9 on: November 25, 2009, 04:56:11 PM »
Happens to me too when running full screen applications. Although it happens rarely so I don't worry about it, and just maximise it again. Nothing freezes when doing so.

Bad_Bud

  • Developers
  • Dark Power
  • *
  • Posts: 4434
Re: Game auto minimizes and I don't know why?
« Reply #10 on: November 25, 2009, 11:16:00 PM »
I don't run NWN in windowed mode. Like I said, it's doing it for all my programs, not just NWN.

I run malwarebytes regularly too and didn't find anything.

I don't either.  I'm saying you need to change it TO windowed mode when the game won't respond to your clicking, and then change it right back to fullscreen and you'll be good to go.

ctrl+enter is the shortcut for changing from fullscreen to windowed.

***

Open nwn.ini in the Neverwinter Nights folder.  Find where it says [Display Options]

Under this section, find where it says "AllowWindowedMode" and make sure it's set to 1.  If you can't find it, add this line to nwn.ini under [Display Options]:

Code: [Select]
AllowWindowedMode=1
« Last Edit: November 25, 2009, 11:19:11 PM by Bad_Bud »


Kendric98

  • Dark Power
  • ******
  • Posts: 1682
  • Omnipotent Overlord of the Omniverse!
Re: Game auto minimizes and I don't know why?
« Reply #11 on: November 25, 2009, 11:27:02 PM »
Its happening to me to and im running xp. Not often but it happens, anouther glitch i have is using a direct conect icon to bypass gamespy sometimes the game will almost load then jam up at 99% after wich when i start mashing Esc. ect to get out of it my whole machine will reset. This also dosent happen very often.

Samson/Tatyanna Costella

ThAnswr

  • Dark Power
  • ******
  • Posts: 3045
  • We all end up the same: Level 20 or dead.
Re: Game auto minimizes and I don't know why?
« Reply #12 on: November 25, 2009, 11:51:56 PM »
I don't run NWN in windowed mode. Like I said, it's doing it for all my programs, not just NWN.

I run malwarebytes regularly too and didn't find anything.

I don't either.  I'm saying you need to change it TO windowed mode when the game won't respond to your clicking, and then change it right back to fullscreen and you'll be good to go.

ctrl+enter is the shortcut for changing from fullscreen to windowed.

***

Open nwn.ini in the Neverwinter Nights folder.  Find where it says [Display Options]

Under this section, find where it says "AllowWindowedMode" and make sure it's set to 1.  If you can't find it, add this line to nwn.ini under [Display Options]:

Code: [Select]
AllowWindowedMode=1

Hell, I can't even find " nwn.ini ".  Does it hide somewhere? 
Sig by Garison



When the going gets weird, the weird turn pro.
Hunter Thompson

"Rock is overpowered, paper is just about right" - Scissors
Thanks Aahz

Kendric98

  • Dark Power
  • ******
  • Posts: 1682
  • Omnipotent Overlord of the Omniverse!
Re: Game auto minimizes and I don't know why?
« Reply #13 on: November 26, 2009, 12:00:10 AM »
Nope its in the nwn folder .ini

Samson/Tatyanna Costella

ThAnswr

  • Dark Power
  • ******
  • Posts: 3045
  • We all end up the same: Level 20 or dead.
Re: Game auto minimizes and I don't know why?
« Reply #14 on: November 26, 2009, 12:14:24 AM »
I'm not kidding:  I don't see a folder called ".ini".    :?
Sig by Garison



When the going gets weird, the weird turn pro.
Hunter Thompson

"Rock is overpowered, paper is just about right" - Scissors
Thanks Aahz

Kendric98

  • Dark Power
  • ******
  • Posts: 1682
  • Omnipotent Overlord of the Omniverse!
Re: Game auto minimizes and I don't know why?
« Reply #15 on: November 26, 2009, 12:16:22 AM »
I dont think its a yellow folder and i might be getting the name wrong cus im not at home but its in there. do a serch for .ini and it will find the files so you can locate it.

Samson/Tatyanna Costella

ThAnswr

  • Dark Power
  • ******
  • Posts: 3045
  • We all end up the same: Level 20 or dead.
Re: Game auto minimizes and I don't know why?
« Reply #16 on: November 26, 2009, 12:20:08 AM »
Thanks for the help.   :D
Sig by Garison



When the going gets weird, the weird turn pro.
Hunter Thompson

"Rock is overpowered, paper is just about right" - Scissors
Thanks Aahz

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: Game auto minimizes and I don't know why?
« Reply #17 on: November 26, 2009, 01:14:53 AM »
I don't run NWN in windowed mode. Like I said, it's doing it for all my programs, not just NWN.

I run malwarebytes regularly too and didn't find anything.

I don't either.  I'm saying you need to change it TO windowed mode when the game won't respond to your clicking, and then change it right back to fullscreen and you'll be good to go.

ctrl+enter is the shortcut for changing from fullscreen to windowed.

***

Open nwn.ini in the Neverwinter Nights folder.  Find where it says [Display Options]

Under this section, find where it says "AllowWindowedMode" and make sure it's set to 1.  If you can't find it, add this line to nwn.ini under [Display Options]:

Code: [Select]
AllowWindowedMode=1
Yeah well, that won't fix the other programs that keep minimizing on me. It's only been doing it for about a week. I still say it's either a Windows update or something like that (did a Java runtime update recently as well). And from the google searches I've done, this is happening to other people who don't even play NWN.

Bluebomber4evr: The Justice, not you, since 2002

failed.bard

  • Guest
Re: Game auto minimizes and I don't know why?
« Reply #18 on: November 26, 2009, 01:23:43 AM »
  It would happen any time another program is temporarily set to be the active one.  I've had google talk windows opening do the same to me before.

  There's an option to change the balance of foreground/background programs somewhere, that might help, though it's really only my best guess at a eork-around.

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: Game auto minimizes and I don't know why?
« Reply #19 on: November 26, 2009, 01:36:58 AM »
  It would happen any time another program is temporarily set to be the active one.  I've had google talk windows opening do the same to me before.

  There's an option to change the balance of foreground/background programs somewhere, that might help, though it's really only my best guess at a eork-around.
hmm, where would that be?

Bluebomber4evr: The Justice, not you, since 2002

failed.bard

  • Guest
Re: Game auto minimizes and I don't know why?
« Reply #20 on: November 26, 2009, 02:20:16 AM »
For XP it's under:

Control panel  :arrow: System  :arrow: Advanced  :arrow: Performance

  It looks like it's defaulted to have priority to programs, though.  I had thought it was a slide bar as opposed to buttons, so maybe vista has more options.  Since I don't have a vista boot anymore, so I can't check what the settings are there, but I imagine they're in a similar place.

Edit:  It's in the same place under win 7 as well, so I'd assume it's the same in Vista.  If the priority wasn't switched I have no ideas though.
« Last Edit: November 26, 2009, 02:28:32 AM by failed.bard »

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: Game auto minimizes and I don't know why?
« Reply #21 on: November 26, 2009, 04:11:34 AM »
tried it, didn't work. I went and disabled a lot of bloatware from my startup, I don't know if that will do it, but it's worth a shot (I made a point of disabling the Java auto-updater).

My mouse has been on the fritz lately though, I'm wondering if that might be the cause?

Bluebomber4evr: The Justice, not you, since 2002

Kendric98

  • Dark Power
  • ******
  • Posts: 1682
  • Omnipotent Overlord of the Omniverse!
Re: Game auto minimizes and I don't know why?
« Reply #22 on: November 26, 2009, 04:14:49 AM »
I also have the prob, lemme know if its java, wasent there an update to windows that just came through could that do it? Im not shure how it would it was only a security update.

Samson/Tatyanna Costella

Bluebomber4evr

  • Head DM, Developer and Ravenloft Trivia Guru/Community Council
  • Administrator
  • Dark Power
  • *
  • Posts: 20692
    • http://www.nwnravenloft.com
Re: Game auto minimizes and I don't know why?
« Reply #23 on: November 26, 2009, 04:41:21 AM »
Didn't work :(

I found this and am trying it: http://support.microsoft.com/kb/313176

I did mess around with my mic/voice settings recently after trying to play Borderlands with my friends and having audio/mic issues. In attempting to turn it off I may have inadvertantly turned something on. I will let you guys know if this works.

Bluebomber4evr: The Justice, not you, since 2002

failed.bard

  • Guest
Re: Game auto minimizes and I don't know why?
« Reply #24 on: November 26, 2009, 06:20:59 AM »
  The only time I ever have it happen is when google talk pops open a new window, which is why I was thinking it was a background program causing it.

  Unfortunately, I have no idea how to track it, unless you're running dual monitors.  With dual monitors you can open the task manager and watch which programs are using resources as you play, and might be able to narrow down where the problem is that way.